OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

HDR - no result displayed


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU]
View previous topic :: View next topic  
Author Message
th3AddY
Newbie


Joined: 12 Jan 2011
Posts: 2

PostPosted: Thu Apr 26, 2012 8:10 pm    Post subject:
HDR - no result displayed
Reply with quote

Hey,

I'm trying to integrate the HDR example into my application, but the screen remains black.

The sole difference is that I'm not using the osg mainloop. Instead I render the scene to a Qt GLWidget and have to call osgViewer::frame() in the paintGL() method.
That seems to be the reason why I don't get any results on the screen. When I modify the example code and replace m_viewer->run() with a separate main loop where viewer->frame() is called repeatedly the same problem occurs.

I also don't really understand how osgPPU writes the result to the screen buffer. Maybe there is something wrong with my camera configuration?
I have my own camera implementation that calculates the view matrix from camera position and attitude every frame.

Sorry for my bad English. I would be very grateful If someone can give me a hint.

Daniel

Edit:

Thats the structure of my scene graph:

Code:
       root
        |
   +----+----+
   |         |
  HUD    SceneNode
             |
         +---+---+
         |       |
        ...  osgPPU::Processor


The Camera is only assigned to the osgViewer and not in the scene graph.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts different result rotating Vec3d for Q... gambr General 2 Tue Jan 24, 2017 10:25 am View latest post
No new posts Insersector doesn't take into account... robertosfield General 5 Mon Oct 17, 2016 11:37 am View latest post
No new posts ReaderWriter result checking anishuz Submission 1 Fri Aug 26, 2016 6:25 am View latest post
No new posts OcclusionQueryNode: do not retrieve t... scrawl Submission 1 Thu Feb 25, 2016 4:41 pm View latest post
No new posts No Textures Displayed Olmun Hilderbran General 1 Mon Sep 21, 2015 11:12 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP