OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osg and collada


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [3rdparty]
View previous topic :: View next topic  
Author Message
jhetfield23
Newbie


Joined: 17 Aug 2012
Posts: 4

PostPosted: Fri Aug 17, 2012 11:43 am    Post subject:
osg and collada
Reply with quote

Hi,

I'm a student currently in the process of finishing my bachelor thesis.at this point i have to code a bit in osg to open a .dae file with a rigged and skinned character.
So i've already built OSG 3.0.1 in VS2010 but now i have to build the collada plugin too since there's no reader to read from the .dae.

i've done things the way the compiling with VS tutorial says in openscenegraph_com documentation.

can someone tell me what i need to do?where to find the collada plugin what with the old site down almost all the time...

i'm sorry if this has been asked before but i've searched a bit and found nothing and i'm kind of time pressed.


Thank you!

Cheers,
Nikos
Back to top
View user's profile Send private message
jhetfield23
Newbie


Joined: 17 Aug 2012
Posts: 4

PostPosted: Mon Aug 20, 2012 10:34 am    Post subject:
OSG loading dae file
Reply with quote

Hi,

Well in the time it has taken for the approval i managed to solve this.so sorry about this.

If i can change this subject to loading a .dae file in OSG.I have to export this skinned and animated character in a .dae file and test if it's exported correctly.
Yesterday I managed to load up the first .dae file but i get all these kinds of messages like:
RigSoftware Bone l_shoulder:sth cannot be loaded and will be skipped.
Which is wierd because I have exported standard joints.


Thank you!

Cheers,
Nikos
Back to top
View user's profile Send private message
jhetfield23
Newbie


Joined: 17 Aug 2012
Posts: 4

PostPosted: Thu Aug 23, 2012 7:32 pm    Post subject:
Reply with quote

Hi,
I have this fully rigged and skinned character with a bit of animation in Maya 2011 that i want to export to collada and load up in osgAnimation/osgViewer and confirm all is well.
So far animation seems to be exported ok since i can import with openCOLLADA import plugin the .dae created and the animation is there.

But I have two problems related to geometry.My character has 6 main shapes and there are 5 more for the eyeballs the teeth and the tongue.Face,Torso,Left_Arm,Right_Arm,Accessories(belt,belt loops,pocket flaps) and Legs(pants without the above and the shoes).
1)when i import to Maya with openCOLLADA importer the .dae file the shape of the Legs is missing when the Accessories shape is there.the joints are there,the animation too.Also the texture are a bit weird.
(MayaImporter attachment)

2)if i load the same .dae in osgViewer i get all shapes except the Face.
the Legs shape is there contrary to the 1st case.Eyeballs,teeth,tongue are there too.the only thing missing is the Face shape.
(osgViewer attachment)

the output in the console before osgViewer comes up,when loading textures and stuff is attachments osgViewer_output 1&2


I also don't get any log with warnings or errors in Maya when i try to export.


as far as the 1st case goes i tried to export to dae just the Legs part and the joint chain having removed the joints from the waist up and when I made a new scene and imported the dae the Legs shape loaded fine.I suspect there is some problem between the Legs shape and all the rest.

if anyone can help it would be much appreciated.i've got till the 31st to turn in the results.


Thank you!

Cheers,
Nikos



EDIT1:i tried to reconstruct the file i was trying to export from without binding.Just the geometry the textures the joints and some animation for the joints.It loaded correctly in Maya from the dae.And the osgViewer loads everything.the only thing not working in both is the textures.would a faulty UV mapping be the problem?i haven't touched it in Maya but from what I've seen it's wrong.but Maya has been loading them correctly so I didn't bother(not my expertise either,no time too)

EDIT2:i bound the new skeleton and geometry parts but a bit differently and everything loads(textures are off again) but all geometry parts,animation,joints,all load.Previously i had done selective binding.for example the arm had only those joints it needed from the shoulder onwards and another one at the clavicle.now i just selected all geometry parts and the Root joint and did a smooth bind with one bind pose(as opposed to my other file) and on the whole joint chain not selected joints.
it's either selective binding or multiple bind poses that cause the problems
Back to top
View user's profile Send private message
jhetfield23
Newbie


Joined: 17 Aug 2012
Posts: 4

PostPosted: Mon Sep 17, 2012 7:11 am    Post subject:
osg and collada
Reply with quote

Hi,
I have this fully rigged and skinned character with a bit of animation in Maya 2011 that i want to export to collada and load up in osgAnimation/osgViewer and confirm all is well.
So far animation seems to be exported ok since i can import with openCOLLADA import plugin the .dae created and the animation is there.

But I have two problems related to geometry.My character has 6 main shapes and there are 5 more for the eyeballs the teeth and the tongue.Face,Torso,Left_Arm,Right_Arm,Accessories(belt,belt loops,pocket flaps) and Legs(pants without the above and the shoes).
1)when i import to Maya with openCOLLADA importer the .dae file the shape of the Legs is missing when the Accessories shape is there.the joints are there,the animation too.Also the texture are a bit weird.
(MayaImporter attachment)

2)if i load the same .dae in osgViewer i get all shapes except the Face.
the Legs shape is there contrary to the 1st case.Eyeballs,teeth,tongue are there too.the only thing missing is the Face shape.
(osgViewer attachment)

the output in the console before osgViewer comes up,when loading textures and stuff is attachments osgViewer_output 1&2


I also don't get any log with warnings or errors in Maya when i try to export.


as far as the 1st case goes i tried to export to dae just the Legs part and the joint chain having removed the joints from the waist up and when I made a new scene and imported the dae the Legs shape loaded fine.I suspect there is some problem between the Legs shape and all the rest.

if anyone can help it would be much appreciated.i've got till the 31st to turn in the results.


Thank you!

Cheers,
Nikos



EDIT1:i tried to reconstruct the file i was trying to export from without binding.Just the geometry the textures the joints and some animation for the joints.It loaded correctly in Maya from the dae.And the osgViewer loads everything.the only thing not working in both is the textures.would a faulty UV mapping be the problem?i haven't touched it in Maya but from what I've seen it's wrong.but Maya has been loading them correctly so I didn't bother(not my expertise either,no time too)

EDIT2:i bound the new skeleton and geometry parts but a bit differently and everything loads(textures are off again) but all geometry parts,animation,joints,all load.Previously i had done selective binding.for example the arm had only those joints it needed from the shoulder onwards and another one at the clavicle.now i just selected all geometry parts and the Root joint and did a smooth bind with one bind pose(as opposed to my other file) and on the whole joint chain not selected joints.
it's either selective binding or multiple bind poses that cause the problems

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=49482#49482




Attachments:
http://forum.openscenegraph.org//files/osgviewer_output2_109.jpg
http://forum.openscenegraph.org//files/osgviewer_output1_328.jpg
http://forum.openscenegraph.org//files/osgviewer_381.jpg
http://forum.openscenegraph.org//files/mayaimporter_184.jpg




------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [3rdparty] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Collada and OSG umadevi2193 General 4 Tue Jan 03, 2017 12:03 pm View latest post
No new posts Crash using current OSG master with c... zonk General 1 Wed Oct 12, 2016 9:17 am View latest post
No new posts Collada in VS2013 cambienta Plugins [osgPlugins] 0 Mon Jul 18, 2016 5:32 pm View latest post
No new posts Osgb to collada Ninin General 3 Wed Jun 22, 2016 2:32 pm View latest post
No new posts fixed visual studio 2015 warnings for... Voerman, L. Submission 1 Wed Jun 08, 2016 1:58 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP