OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Help with OSGART building with VS2010


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [3rdparty]
View previous topic :: View next topic  
Author Message
ishi3000
Newbie


Joined: 28 Mar 2013
Posts: 1

PostPosted: Thu Mar 28, 2013 3:53 am    Post subject:
Help with OSGART building with VS2010
Reply with quote

Hi,
I just started working with OpenSceneGraph and ARToolKit and have already installed OpenSceneGraph 3.0.1 and ARToolKit 2.72 on my windows 64 bit machine.

I know I am asking a very basic question; I have been having trouble understanding how to properly configure and build OSGART under the above given conditions. The information available (related to OSGART building on windows) is either very vague, non-comprehensive or outdated Sad Sad.

Would anyone be able to point me to a tutorial on how to build OSGART 2.0 on windows with VS 2010?

Thanks a lot.

Any kind of help is much appreciated.


Thank you!

Cheers,
ishi3000
Back to top
View user's profile Send private message
raphael (Raphael Grasset)
Newbie


Joined: 21 Feb 2013
Posts: 6
Location: Graz, Austria

PostPosted: Mon Apr 01, 2013 11:26 am    Post subject:
Reply with quote

Hi ishii3000,

We have only recently restarted to work on OSGART, and will update soon the website with a new documentation (as well as new architecture, new examples, etc).

Until then, please follow this process:
- Access the last version of OSGART from our github repository:
https://github.com/seichter/osgART/
- Install either OSG 3.0.1 or the 3.1.5 developer release (in the future we will rely on this one due to the significant fixes for the Android platform) and be sure that your OSG_ROOT env. variable is defined and point to your OSG repository containing include and libs files.
- Compile and use the artoolkit version from:
https://github.com/seichter/artoolkit
- run the OSGART cmake and tick the options for installing artoolkit plugins: OSGART_PLUGINS_VIDEO_ARTOOLKIT, OSGART_PLUGINS_TRACKING_ARTOOLKIT
- configure, and you will be asked to enter path for the ARToolkit include directory and the path to the libAR.lib (the cmake will automatically find the other ARToolkit libraries).
- compile osgart,
- install or copy the content of bin and the dll in lib in your OSG bin. You also need to copy the content from share\osgart\ to your bin directory (or provide a path access). For ARToolKit on windows you need to add the ARvideo.dll and DSVL.dll in the bin directory.
- run the osgartsimpleartoolkit

Be aware that the interface of the library may change slightly over the last few weeks.

If you have any more issues, please pm me.
...
Thank you!

Cheers,
Raphael
OSGART Author
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [3rdparty] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Building OSG for Android -- Windowing... bwhaines Build system [build] 0 Sun Apr 23, 2017 2:01 am View latest post
No new posts Error building terrain with shapefile... robertosfield VirtualPlanetBuilder [vpb] 0 Mon Feb 06, 2017 9:11 am View latest post
No new posts Error building terrain with shapefile... vinothrajendran4 VirtualPlanetBuilder [vpb] 0 Mon Feb 06, 2017 6:24 am View latest post
No new posts Problem building .dae format file us... vinothrajendran4 VirtualPlanetBuilder [vpb] 4 Wed Jan 18, 2017 12:05 pm View latest post
No new posts Disable FFMpeg while building OSG? jiapei100 Build system [build] 1 Fri Jan 06, 2017 11:36 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP