OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

FBX only Black Texture shown


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins]
View previous topic :: View next topic  
Author Message
Morkeleb
Newbie


Joined: 19 Mar 2013
Posts: 10

PostPosted: Tue Mar 19, 2013 1:10 pm    Post subject:
FBX only Black Texture shown
Reply with quote

Hi,

i am new to this, so bear with me.
The Problem i encountered is:
after exporting from 3Ds Max to .fbx
i could easily open the .fbx file with MotionBuilder on the same Pc.

But if i try looking at the Model with the osganimationviewer on a Linux system, i can see the Animations but the Model is Black without Texture.

So far, i tried:
export with embedded Media
export with ascii and then change the .tga locations with Texteditor

but the Model remains black.
What is it that i forgot?

Thank you!

Cheers,
Michael
Back to top
View user's profile Send private message
hybr
Appreciator


Joined: 26 Jun 2009
Posts: 454

PostPosted: Mon Mar 25, 2013 2:52 pm    Post subject:
FBX only Black Texture shown
Reply with quote

Hi

it can be down to your osg build dont have tga plugin, or some materials that osg fbx plugin dont know how to interpret correctly. You can convert your model to .osg or .osgt and check if there are textures etc. IIRC current osg fbx plugin have support for diffuse, reflection, opacity, self-illumination maps

Cheers.

25.03.2013, 15:39, "Michael Borst" <>:
Quote:
Hi,

i am new to this, so bear with me.
The Problem i encountered is:
after exporting from 3Ds Max to .fbx
i could easily open the .fbx file with MotionBuilder on the same Pc.

But if i try looking at the Model with the osganimationviewer on a Linux system, i can see the Animations but the Model is Black without Texture.

So far, i tried:
export  with embedded Media
export with ascii and then change the .tga locations with Texteditor

but the Model remains black.
What is it that i forgot?

Thank you!

Cheers,
Michael

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=53158#53158




------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Sebastian Messerschmidt
Guest





PostPosted: Mon Mar 25, 2013 5:21 pm    Post subject:
FBX only Black Texture shown
Reply with quote

Hello Michael,

I have exactly the same problem with some fbx files. Unfortunately this
seems to be related to the fbx importer not evaluating the
texture-material mixing correctly.
The problem is that the diffuse color indeed is black and the texture is
not applied as decal.
I've tried to fix this but with no luck, as I don't have too much
experience with the fbx format.
Maybe the author of the FBX plugin can drop a line regarding the
proposed fix.

cheers
Sebastian
Quote:
Hi,

i am new to this, so bear with me.
The Problem i encountered is:
after exporting from 3Ds Max to .fbx
i could easily open the .fbx file with MotionBuilder on the same Pc.

But if i try looking at the Model with the osganimationviewer on a Linux system, i can see the Animations but the Model is Black without Texture.

So far, i tried:
export with embedded Media
export with ascii and then change the .tga locations with Texteditor

but the Model remains black.
What is it that i forgot?

Thank you!

Cheers,
Michael

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=53158#53158









------------------
Post generated by Mail2Forum
Back to top
Morkeleb
Newbie


Joined: 19 Mar 2013
Posts: 10

PostPosted: Mon Apr 08, 2013 10:57 am    Post subject:
Reply with quote

Hi,

I fixed the issue by importing the Models in 3ds Max and there i changed the diffuse Color from black to white and everything works.

But what do i do when i don't own such a software and just buy some Models.

Thank you!

Cheers,
Michael
Back to top
View user's profile Send private message
Morkeleb
Newbie


Joined: 19 Mar 2013
Posts: 10

PostPosted: Mon Apr 22, 2013 7:36 pm    Post subject:
FBX only Black Texture shown
Reply with quote

Hi,

I fixed the issue by importing the Models in 3ds Max and there i changed the diffuse Color from black to white and everything works.

But what do i do when i don't own such a software and just buy some Models.

Thank you!

Cheers,
Michael

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=53488#53488







------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Morkeleb
Newbie


Joined: 19 Mar 2013
Posts: 10

PostPosted: Mon May 27, 2013 7:29 am    Post subject:
Reply with quote

I managed to do it another way.
when loading the Model override its Diffuse colour and Ambient colour to White and everything works fine.

Cheers,
Michael
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Changing minFilter/magFilter of textu... Sailesh General 2 Tue Apr 16, 2019 7:12 pm View latest post
No new posts override the texture with the gl_frag... GarfieldPig General 1 Sun Apr 14, 2019 8:31 am View latest post
No new posts EXTERNAL: Re: EXTERNAL: Re: Texture u... Rowley, Marlin R General 1 Thu Mar 14, 2019 5:56 pm View latest post
No new posts EXTERNAL: Re: Texture unit not turni... Rowley, Marlin R General 1 Thu Mar 14, 2019 2:06 pm View latest post
No new posts Texture unit not turning ON Rowley, Marlin R General 1 Wed Mar 13, 2019 6:37 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP