OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Refraction Map issue: isn't visible...


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgOcean [osgOcean]
View previous topic :: View next topic  
Author Message
Paradox
Appreciator


Joined: 19 Apr 2010
Posts: 121

PostPosted: Fri Jun 14, 2013 3:43 pm    Post subject:
Refraction Map issue: isn't visible...
Reply with quote

Hi,

I'm using still now OsgOcean rev 208. I'm update to the last rev 258. Refraction seems don't work. I have a scene with refraction enabled, withe rev208 I can see the refraction, not with the rev258.

Someone has reported this issue? I'm looking now around the refracition code, but is a bit expansive...

Thank you!

Cheers,
Dario
Back to top
View user's profile Send private message
Trajce Nikolov NICK
Guest





PostPosted: Sat Jun 15, 2013 7:40 am    Post subject:
Refraction Map issue: isn't visible...
Reply with quote

Hi Dario,

it should work with the latest from trunk I think. It's been a while since I used osgOcean but somehow it worked for me. Just fyi


Nick



On Fri, Jun 14, 2013 at 5:43 PM, Dario Minieri < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,

I'm using still now OsgOcean rev 208. I'm update to the last rev 258. Refraction seems don't work. I have a scene with refraction enabled, withe rev208 I can see the refraction, not with the rev258.

Someone has reported this issue?  I'm looking now around the refracition code, but is a bit expansive...

Thank you!

Cheers,
Dario

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=54620#54620





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




--
trajce nikolov nick

------------------
Post generated by Mail2Forum
Back to top
Paradox
Appreciator


Joined: 19 Apr 2010
Posts: 121

PostPosted: Sat Jun 15, 2013 5:19 pm    Post subject:
Reply with quote

Hi,

Hummm....maybe is my fault in somewhat, but I make two snapshot of oceanExample and the refraction seems to me don't works. I've tested others my scenes and the result is the same.

1. snap_no_refraction1.jpg shows the example scene without refraction and, in effect, apart the rev208 "artifacts", the refraction is not visible.

2. snap_with_refraction1.jpg shows the example scene with refraction, and, the rev 258 is the same as above (no refraction in any cases), rev 208 shows the refraction of the island above water dynamic line.

Tested on Nvidia GTX 560Ti and GTX 570 (on GTX 570 there are no "artifacts" in the first case).

There are some parameters or others changes to make which are changed and I forgot?

Thank you!

Cheers,
Dario
Back to top
View user's profile Send private message
Trajce Nikolov NICK
Guest





PostPosted: Sat Jun 15, 2013 9:16 pm    Post subject:
Refraction Map issue: isn't visible...
Reply with quote

maybe you post a code snippet of your settings if someone can look at

Nick



On Sat, Jun 15, 2013 at 7:19 PM, Dario Minieri < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,

Hummm....maybe is my fault in somewhat, but I make two snapshot of oceanExample and the refraction seems to me don't works. I've tested others my scenes and the result is the same.

snap_no_refraction1.jpg shows the example scene without refraction and, in effect, apart the rev208 "artifacts", the refraction is not visible.

snap_with_refraction1.jpg shows the example scene with refraction, and, the rev 258 is the same as above (no refraction in any cases), rev 208 shows the refraction of the island above water dynamic line.

There are some parameters or others changes to make which are changed and I forgot?

Thank you!

Cheers,
Dario

------------------
Read this topic online here:

http://forum.openscenegraph.org/viewtopic.php?p=54633#54633




_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org





--
trajce nikolov nick

------------------
Post generated by Mail2Forum
Back to top
Paradox
Appreciator


Joined: 19 Apr 2010
Posts: 121

PostPosted: Sun Jun 16, 2013 11:35 am    Post subject:
Reply with quote

Hi,

Mha, this is strange, because the snapshot showed above are oceanExample related with no alteration of code and options (different settings are changed in realtime using the feature of the example). I'm looking into refraction code and, in effect, this is drastically changed between two version: in rev208 the refraction is made by a dedicated camera pass render, in last rev258 not. I don't know if this problem can be a videocard problem...If you execute the oceanExample you can notice the same behaviour or it works for you?


Thank you!

Cheers,
Dario
Back to top
View user's profile Send private message
Paradox
Appreciator


Joined: 19 Apr 2010
Posts: 121

PostPosted: Sun Jun 16, 2013 12:24 pm    Post subject:
Reply with quote

Hi,

Using last dev osg release (3.1.7) and trunk osgOcean revision (I'm using the suggested tags version) works....


Thank you!

Cheers,
Dario
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgOcean [osgOcean] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Building OSG for Android -- Windowing... bwhaines Build system [build] 1 Sun Apr 23, 2017 2:01 am View latest post
No new posts Having an issue with OSG plugins error. Brigham Keys, Esq. General 2 Wed Apr 12, 2017 5:24 am View latest post
No new posts How to set maximum visible distance? Daven Hem General 4 Mon Feb 13, 2017 10:14 pm View latest post
No new posts issue with 3ds model after upgrading ... filnet General 5 Thu Feb 09, 2017 1:27 pm View latest post
No new posts osgShadow issue juilear General 0 Thu Feb 09, 2017 7:54 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP