OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgdem crash


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb]
View previous topic :: View next topic  
Author Message
Maia
User


Joined: 13 Oct 2011
Posts: 63

PostPosted: Thu Dec 05, 2013 8:04 pm    Post subject:
osgdem crash
Reply with quote

Hi,

I have OSG 3.0.1, 32 bits, Visual C++ 9 2008 and VirtualPlanetBuilder on a Windows 7 64bits.

I tried to run some example with VPB or osgdem alone, but it crashes.

I found this topic:
http://forum.openscenegraph.org/viewtopic.php?t=11865

but it seems not resolved yet ?

Does anyone solve it ?

Thank you!

Cheers,
Maia
Back to top
View user's profile Send private message
SMesserschmidt (Sebastian Messerschmidt)
Forum Moderator


Joined: 10 Sep 2013
Posts: 725

PostPosted: Thu Dec 05, 2013 8:59 pm    Post subject:
osgdem crash
Reply with quote

Hi Maia,

Did you compile VPB on your own?
What exactly crashes? Do you get an unhandled exception or what is the
error message?
Your post simply doesn't give enough information to help you.
I've been using VPB for years now and the only occasions where it
crashed when data was corrupted or debug/release builds were mixed.

cheers
Sebastian
Quote:
Hi,

I have OSG 3.0.1, 32 bits, Visual C++ 9 2008 and VirtualPlanetBuilder on a Windows 7 64bits.

I tried to run some example with VPB or osgdem alone, but it crashes.

I found this topic:
http://forum.openscenegraph.org/viewtopic.php?t=11865

but it seems not resolved yet ?

Does anyone solve it ?

Thank you!

Cheers,
Maia

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=57568#57568









------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Maia
User


Joined: 13 Oct 2011
Posts: 63

PostPosted: Mon Dec 16, 2013 8:10 pm    Post subject:
Re: osgdem crash
Reply with quote

Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia
Back to top
View user's profile Send private message
Jason Beverage
Guest





PostPosted: Tue Dec 17, 2013 2:24 am    Post subject:
osgdem crash
Reply with quote

Hi Maia,

What issues are you having with osgEarth?  Is it crashing in the same way as VPB?


Jason



On Mon, Dec 16, 2013 at 3:10 PM, Maia Randria < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=57694#57694





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
Jason Beverage
Guest





PostPosted: Tue Dec 17, 2013 2:24 am    Post subject:
osgdem crash
Reply with quote

Nevermind, saw your email on the osgEarth forum.  Did Glenn's patch work for you?


On Mon, Dec 16, 2013 at 9:23 PM, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Maia,

What issues are you having with osgEarth?  Is it crashing in the same way as VPB?


Jason



On Mon, Dec 16, 2013 at 3:10 PM, Maia Randria < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=57694#57694





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org







------------------
Post generated by Mail2Forum
Back to top
Veneree
Guest





PostPosted: Wed Dec 18, 2013 2:49 am    Post subject:
osgdem crash
Reply with quote

Hi Jason,
OsgEarth needs osgQT to work and I just achieved to build osg with osgQT. I hope to build osgEarth successfully now. I think I was also lost for GDAL and need to choose the right one to be installed. May I ask you which one did you use ? I wanted to start with VPB as there are examples on it in the OSG cookbook, and at the same time I read some posts about using OsgEarth instead of VPB. So I will try the two. Thanks, Maia

Envoyé de mon iPod

Le 2013-12-16 à 21:24, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> a écrit :



Quote:
Nevermind, saw your email on the osgEarth forum. Did Glenn's patch work for you?


On Mon, Dec 16, 2013 at 9:23 PM, Jason Beverage <[url=mailto:] (
Only registered users can see emails on this board!
Get registred or enter the forums!
)[/url]> wrote:
Quote:
Hi Maia,

What issues are you having with osgEarth? Is it crashing in the same way as VPB?


Jason



On Mon, Dec 16, 2013 at 3:10 PM, Maia Randria <[url=mailto:] (
Only registered users can see emails on this board!
Get registred or enter the forums!
)[/url]> wrote:
Quote:
Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=57694#57694





_______________________________________________
osg-users mailing list
[url=mailto:] (
Only registered users can see emails on this board!
Get registred or enter the forums!
)[/url]
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org









_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
Jason Beverage
Guest





PostPosted: Wed Dec 18, 2013 7:37 pm    Post subject:
osgdem crash
Reply with quote

Hi Maia,

If you're on Windows I've been using the pre-built GDAL binaries at http://www.gisinternals.com/sdk/ rather than building GDAL myself.  I use GDAL 1.9 personally but osgEarth should work fine with later versions.


GDAL is pretty easy to build but when you start needing extra dependencies it can be a little bit of a pain tracking everything down so I like those pre-built ones.


Jason



On Tue, Dec 17, 2013 at 9:48 PM, Veneree < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Jason,
OsgEarth needs osgQT to work and I just achieved to build osg with osgQT. I hope to build osgEarth successfully now. I think I was also lost for GDAL and need to choose the right one to be installed. May I ask you which one did you use ? I wanted to start with VPB as there are examples on it in the OSG cookbook, and at the same time I read some posts about using OsgEarth instead of VPB. So I will try the two. Thanks, Maia 

Envoyé de mon iPod

Le 2013-12-16 à 21:24, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> a écrit :



Quote:
Nevermind, saw your email on the osgEarth forum.  Did Glenn's patch work for you?


On Mon, Dec 16, 2013 at 9:23 PM, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
) (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Maia,

What issues are you having with osgEarth?  Is it crashing in the same way as VPB?


Jason



On Mon, Dec 16, 2013 at 3:10 PM, Maia Randria < (
Only registered users can see emails on this board!
Get registred or enter the forums!
) (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia

------------------
Read this topic online here:
[/url][url=http://forum.openscenegraph.org/viewtopic.php?p=57694#57694]http://forum.openscenegraph.org/viewtopic.php?p=57694#57694





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
) (
Only registered users can see emails on this board!
Get registred or enter the forums!
)
[/url][url=http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org]http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org









_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
Vénérée Randrianarisoa
Guest





PostPosted: Thu Dec 19, 2013 3:06 am    Post subject:
osgdem crash
Reply with quote

Hi Jason,
Yes, i used the same binaries as yours on this website,I think that my mistake is about the platform as I have Windows 7 64bits, I installed the x64 though my OSG is x86. I have to check everything for release or debug also. I will do that after Christmas I hope so, thanks a lot and I hope you a Merry Christmas. Maia
Le 18 déc. 2013 14:37, "Jason Beverage" < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> a écrit :
Quote:

Hi Maia,

If you're on Windows I've been using the pre-built GDAL binaries at http://www.gisinternals.com/sdk/ rather than building GDAL myself.  I use GDAL 1.9 personally but osgEarth should work fine with later versions.

GDAL is pretty easy to build but when you start needing extra dependencies it can be a little bit of a pain tracking everything down so I like those pre-built ones.

Jason


On Tue, Dec 17, 2013 at 9:48 PM, Veneree < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Jason,
OsgEarth needs osgQT to work and I just achieved to build osg with osgQT. I hope to build osgEarth successfully now. I think I was also lost for GDAL and need to choose the right one to be installed. May I ask you which one did you use ? I wanted to start with VPB as there are examples on it in the OSG cookbook, and at the same time I read some posts about using OsgEarth instead of VPB. So I will try the two. Thanks, Maia 

Envoyé de mon iPod

Le 2013-12-16 à 21:24, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> a écrit :

Quote:
Nevermind, saw your email on the osgEarth forum.  Did Glenn's patch work for you?


On Mon, Dec 16, 2013 at 9:23 PM, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Maia,

What issues are you having with osgEarth?  Is it crashing in the same way as VPB?

Jason


On Mon, Dec 16, 2013 at 3:10 PM, Maia Randria < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=57694#57694





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
Jason Beverage
Guest





PostPosted: Fri Dec 20, 2013 3:29 pm    Post subject:
osgdem crash
Reply with quote

Yeah dependencies can be a mess when you're trying to avoid mixing x86 vs x64 and Debug vs Release.  It would be great if you got more build warnings about those issues rather than just crashing applications Smile

You have a Merry Christmas as well!


Jason



On Wed, Dec 18, 2013 at 10:06 PM, Vénérée Randrianarisoa < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Jason,
Yes, i used the same binaries as yours on this website,I think that my mistake is about the platform as I have Windows 7 64bits, I installed the x64 though my OSG is x86. I have to check everything for release or debug also. I will do that after Christmas I hope so, thanks a lot and I hope you a Merry Christmas. Maia
Le 18 déc. 2013 14:37, "Jason Beverage" < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> a écrit :
Quote:

Hi Maia,

If you're on Windows I've been using the pre-built GDAL binaries at http://www.gisinternals.com/sdk/ rather than building GDAL myself.  I use GDAL 1.9 personally but osgEarth should work fine with later versions.

GDAL is pretty easy to build but when you start needing extra dependencies it can be a little bit of a pain tracking everything down so I like those pre-built ones.

Jason


On Tue, Dec 17, 2013 at 9:48 PM, Veneree < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Jason,
OsgEarth needs osgQT to work and I just achieved to build osg with osgQT. I hope to build osgEarth successfully now. I think I was also lost for GDAL and need to choose the right one to be installed. May I ask you which one did you use ? I wanted to start with VPB as there are examples on it in the OSG cookbook, and at the same time I read some posts about using OsgEarth instead of VPB. So I will try the two. Thanks, Maia 

Envoyé de mon iPod

Le 2013-12-16 à 21:24, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> a écrit :

Quote:
Nevermind, saw your email on the osgEarth forum.  Did Glenn's patch work for you?


On Mon, Dec 16, 2013 at 9:23 PM, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Maia,

What issues are you having with osgEarth?  Is it crashing in the same way as VPB?

Jason


On Mon, Dec 16, 2013 at 3:10 PM, Maia Randria < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi Sebastian,
Thank you for replying.

I build VBP on my own (Cmake). I will check again for debug/release.
I have trouble with osgEarth too so I need to fix this.

Thanks,
Maia

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=57694#57694





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10892

PostPosted: Fri Dec 20, 2013 4:03 pm    Post subject:
osgdem crash
Reply with quote

On 20 December 2013 15:29, Jason Beverage < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Yeah dependencies can be a mess when you're trying to avoid mixing x86 vs x64 and Debug vs Release.  It would be great if you got more build warnings about those issues rather than just crashing applications Smile


Something along the lines : "WARNING, WINDOWS SOFTWARE BEING RUN, BE PREPARED FOR CRASHES DUE TO SILLY MS COMPILER/LINKERS DESIGN FLAWS" Smile


 
Quote:
You have a Merry Christmas as well!



Thankyou, greetings to you too Smile


Robert.
 

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Crash on Windows 10 with a Display Li... efson General 2 Thu Apr 27, 2017 9:03 am View latest post
No new posts OSG crash on startup guyv General 3 Wed Apr 26, 2017 5:07 pm View latest post
No new posts Crash using current OSG master with c... zonk General 1 Wed Oct 12, 2016 9:17 am View latest post
No new posts Crash on exit (graphics thread removi... scrawl General 9 Sun Aug 14, 2016 6:02 pm View latest post
No new posts Origin of computing maximum level in ... maya leonard General 1 Mon Jun 20, 2016 10:11 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP