OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

build osgWorks and osgBullet


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
LaytonG123
Newbie


Joined: 24 Dec 2013
Posts: 6

PostPosted: Tue Dec 24, 2013 8:13 pm    Post subject:
build osgWorks and osgBullet
Reply with quote

I'm trying to build osgWorks and osgBullet on windows 7 using cmake and I'm having some troubles with dependencies.

In order for osgBullet to work I first need to build and compile osgWorks. I placed the code for osgWorks into a folder C:\osgw2 I run "Configure" in cmake for the cmakelists.txt in osgw2 and I get the following message:

------------------------------------------------------------------------------

Could NOT find osgGA (missing: OSGGA_LIBRARY)
Could NOT find osgText (missing: OSGTEXT_LIBRARY)
Could NOT find osgViewer (missing: OSGVIEWER_LIBRARY)
Could NOT find osgSim (missing: OSGSIM_LIBRARY)
Could NOT find osgDB (missing: OSGDB_LIBRARY)
Could NOT find osgUtil (missing: OSGUTIL_LIBRARY)
Could NOT find osg (missing: OSG_LIBRARY)
Could NOT find OpenThreads (missing: OPENTHREADS_LIBRARY)
CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find OpenSceneGraph (missing: OSGGA_FOUND OSGTEXT_FOUND
OSGVIEWER_FOUND OSGSIM_FOUND OSGDB_FOUND OSGUTIL_FOUND OSG_FOUND
OPENTHREADS_FOUND) (found suitable version "3.0.0", minimum required is
"2.6.1")
Call Stack (most recent call first):
C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindOpenSceneGraph.cmake:187 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeModules/FindOSGHelper.cmake:125 (find_package)
CMakeLists.txt:41 (include)


Configuring incomplete, errors occurred!

------------------------------------------------------------------------------

Question 1:
Does it matter that I'm using the debug version for each of these "missing" libraries? When I examine CMakeCache.txt it shows that CMake was able to find the debug versions of each of the libraries.

Question 2:
What is the meaning of the Bottom two errors "Call Stack (most recent call first):"?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts osgQt Build error bclay General 2 Wed Jan 17, 2018 9:53 pm View latest post
No new posts Link error while build plugins gabriella seth General 3 Tue Jan 09, 2018 12:58 am View latest post
No new posts compile osg on Debian Jessie, after b... wartburgritter Build system [build] 3 Mon Dec 18, 2017 12:24 pm View latest post
No new posts Build OSG on iOS with support OpenGLE... xerxses Build system [build] 1 Tue Dec 12, 2017 1:09 pm View latest post
No new posts iOS build guide locked/checked out on... tomhog General 2 Fri Apr 21, 2017 10:43 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP