OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

vertex glcompileshader failed fragmen glcompileshader failed


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum]
View previous topic :: View next topic  
Author Message
t.tirupathi@gmail.com (tirupathi reddy)
Newbie


Joined: 24 Apr 2014
Posts: 1

PostPosted: Thu Apr 24, 2014 6:11 am    Post subject:
vertex glcompileshader failed fragmen glcompileshader failed
Reply with quote

Hi,

when I am starting osg based image display, glxgears any other gl related applications I am getting these errors.

I was wondering, since this problem started coming last two weeks, earleir it was good.

And the problem is not consistent, some times it is executing fine, some times it is giving problem.

Once logout and login, the problem goes off, and it comes after three or four consecutive execution of my display application. When display application gives Buss error, or segmentation fault, the above mentioned problem starts and it persists till logout and login.

Even sometimes it is causing reboot of the system.

Can any body help. I tried to debug my application using gdb, but it is not showing any error in my application, some addresses it is showing in the program/call stack.
Please if any body faced similar problem help me.



Thank you!

Cheers,
tirupathi
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11192

PostPosted: Wed Apr 30, 2014 9:35 am    Post subject:
vertex glcompileshader failed fragmen glcompileshader failed
Reply with quote

HI Tirupathi,

It sounds very much like the OpenGL driver that you have installed is
causing the problem. Perhaps a recent update to it has introduced the
problem.

What hardware/OS/OpenGl drivers are you using?

Robert.

On 24 April 2014 07:11, tirupathi reddy <> wrote:
Quote:
Hi,

when I am starting osg based image display, glxgears any other gl related applications I am getting these errors.

I was wondering, since this problem started coming last two weeks, earleir it was good.

And the problem is not consistent, some times it is executing fine, some times it is giving problem.

Once logout and login, the problem goes off, and it comes after three or four consecutive execution of my display application. When display application gives Buss error, or segmentation fault, the above mentioned problem starts and it persists till logout and login.

Even sometimes it is causing reboot of the system.

Can any body help. I tried to debug my application using gdb, but it is not showing any error in my application, some addresses it is showing in the program/call stack.
Please if any body faced similar problem help me.



Thank you!

Cheers,
tirupathi

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=59135#59135








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Post Processing Effect - Vertex Shade... guyv General 27 Sat Sep 16, 2017 3:48 am View latest post
No new posts Pro Process Effect Vertex Shader not ... guyv General 1 Fri Sep 15, 2017 10:22 pm View latest post
No new posts Post Process Effect Vertex Shader guyv General 1 Fri Sep 15, 2017 8:29 pm View latest post
No new posts using modern shaders with osg - setti... antiro42 General 18 Fri Sep 01, 2017 9:30 am View latest post
No new posts Scale problem while transforming obje... YuraIU02 General 1 Sat Apr 15, 2017 4:26 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP