OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Error building OSG 3.2.0 (FFMPEG)


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
curVV
Newbie


Joined: 06 May 2014
Posts: 1

PostPosted: Tue May 06, 2014 1:14 pm    Post subject:
Error building OSG 3.2.0 (FFMPEG)
Reply with quote

Hi, I'm having problems building OSG 3.2.0 on Linux Mint.

Error:
Code:
[ 96%] Building CXX object src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/FFmpegDecoderAudio.o
/home/curvv/Downloads/OpenSceneGraph-3.2.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp: In function ‘int osgFFmpeg::decode_audio(AVCodecContext*, int16_t*, int*, const uint8_t*, int)’:
/home/curvv/Downloads/OpenSceneGraph-3.2.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp:33:72: error: ‘avcodec_decode_audio3’ was not declared in this scope
/home/curvv/Downloads/OpenSceneGraph-3.2.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp: In member function ‘void osgFFmpeg::FFmpegDecoderAudio::open(AVStream*)’:
/home/curvv/Downloads/OpenSceneGraph-3.2.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp:103:36: error: ‘CODEC_ID_NONE’ was not declared in this scope
/home/curvv/Downloads/OpenSceneGraph-3.2.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp: In function ‘int osgFFmpeg::decode_audio(AVCodecContext*, int16_t*, int*, const uint8_t*, int)’:
/home/curvv/Downloads/OpenSceneGraph-3.2.0/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp:38:1: warning: control reaches end of non-void function [-Wreturn-type]
make[2]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/FFmpegDecoderAudio.o] Error 1
make[1]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/all] Error 2
make: *** [all] Error 2


I have libav, which is prob why this happens. But I'm building OSG for use with FlightGear which doesn't need OSG's FFMPEG support. So how can I build without FFMpeg? I tried with
-DCMAKE_WITH_FFMPEG=OFF
-DWITH_FFMPEG=OFF

but no joy.

Thanks[/code]
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts use vs2013 to build osg3.6.3, some er... FreeSouth General 0 Sat Dec 08, 2018 3:26 pm View latest post
No new posts playing videos with audio channels wi... Trajce Nikolov NICK General 7 Wed Nov 21, 2018 9:17 pm View latest post
No new posts Building on macOS 10.14 Ulrich Hertlein General 1 Sun Nov 11, 2018 12:45 pm View latest post
No new posts OpenGL viewport error (with Oculus) Riccardo Corsi General 6 Wed Oct 17, 2018 10:44 am View latest post
No new posts building the fbx plugin Tare Plugins [osgPlugins] 2 Wed Oct 10, 2018 3:04 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP