OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

OSG on 64bit Linux seg faults


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum]
View previous topic :: View next topic  
Author Message
manikandarajanr1 (Manikandarajan Ramalingam)
Newbie


Joined: 05 Nov 2014
Posts: 2

PostPosted: Wed Nov 12, 2014 12:00 pm    Post subject:
OSG on 64bit Linux seg faults
Reply with quote

Hi,
I am a bit new to OSG. I have build and install OSG on Ubuntu 12.04 64 bit. When i try to run a sample example i am getting a segfault. Debug trace is as below:
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff52d7241 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) bt
#0 0x00007ffff52d7241 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007ffff5ae55d0 in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string(char const*, std::allocator<char> const&) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#2 0x000000000077c3e1 in osg::initNotifyLevel() ()
#3 0x000000000077ca51 in osg::isNotifyEnabled(osg::NotifySeverity) ()
#4 0x000000000093a3ec in graphicswindow_X11 ()
#5 0x000000000069a595 in _GLOBAL__sub_I__Z9setViewerRN9osgViewer6ViewerEfff ()
#6 0x0000000000e9533d in __libc_csu_init ()
#7 0x00007ffff5195700 in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#8 0x00000000006e8249 in _start ()


The above example is build with OSG static library, i tried doing the same with shared object library. But nothing helped i got the same segfault. Any suggestion to fix this would of great help.

Quick responses are appreciated.

Thanks in advance

Mani
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts PBuffer causing error when profiling ... jsmitq General 1 Thu Jun 08, 2017 4:24 pm View latest post
No new posts Cross-platform guide for Linux, macOS... kornerr Announcement [ANN] 3 Mon Apr 03, 2017 5:05 pm View latest post
No new posts Up to date tutorials for linux Rodrigo General 7 Wed Mar 01, 2017 9:57 pm View latest post
No new posts [Solved] Bug while updating geometry ... Nikkitta General 2 Thu Jan 26, 2017 9:27 am View latest post
No new posts a linux dialog starting to blur while... lq37 General 2 Tue Nov 29, 2016 4:57 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP