OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Loading dae-File results in the object without textures


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins]
View previous topic :: View next topic  
Author Message
Assassin
User


Joined: 02 Feb 2015
Posts: 22

PostPosted: Mon Feb 02, 2015 11:17 am    Post subject:
Loading dae-File results in the object without textures
Reply with quote

Hi

I already searched in the forum, if there is any solution for my problem. But did not find any.

I've been trying to load a dae-File with
"osg::ref_ptr<osg::Node> building = new osg::Node();
building = osgDB::readNodeFile("D:/StraßenSzene/Modelle/House/House.dae");" .

When I compile my project it shows the house without a texture.

When I drag the dae-File in the osgviewer.exe or open it over the console "osgviewer house.dae" it shows the model with its textures.

I hope anyone can show me what i am doing wrong, or give me an example code where a dae-file is loaded.

When I set the exact path of each object in the OSG_FILE_PATH it works...

At the moment i try to debug with the debug level of osg. Hope I get a few information out of it.

I am using osg version 3.3.3. If you need any other information, just ask me Wink.
...

Thank you!

Cheers,
Andreas
Back to top
View user's profile Send private message
Assassin
User


Joined: 02 Feb 2015
Posts: 22

PostPosted: Wed Feb 04, 2015 11:21 am    Post subject:
Reply with quote

Hi,

sorry for dumb question.
Found the problem.
It was the letter "ß" in the path to the objects.

The diffuse texture is loading fine now =).

Lets see how to activate the specular.

...

Thank you!

Cheers,
Andreas
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts [CubeMap with mipmaps] About loading IBL mp3butcher General 3 Sat Nov 04, 2017 12:37 am View latest post
No new posts Backward compatibility of osgb file t... saedrna1 General 4 Thu Nov 02, 2017 8:20 am View latest post
No new posts Tiff File to .Osg file conversion Latha Rani General 2 Tue Oct 24, 2017 7:06 am View latest post
No new posts Multi-threaded usage of textures anishuz Submission 7 Tue Oct 17, 2017 8:38 am View latest post
No new posts custom file GeekOwl Plugins [osgPlugins] 1 Thu Oct 12, 2017 12:32 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP