OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Xcode: Cannot find install manifest


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
muzzleburst (Robert Graf)
Newbie


Joined: 18 Nov 2014
Posts: 12

PostPosted: Tue Feb 03, 2015 9:48 pm    Post subject:
Xcode: Cannot find install manifest
Reply with quote

Howdy all,

I was wondering if anyone has run into this "Cannot find install manifest" build error with Xcode, or knows how to fix it:


Code:
PhaseScriptExecution CMake\ Rules /Users/robert/Documents/691/Prototype/build/osg/OpenSceneGraph.build/Debug/uninstall.build/Script-495994A8D09A48648262044A.sh
cd /Users/robert/Documents/691/Prototype/src/osg
/bin/sh -c /Users/robert/Documents/691/Prototype/build/osg/OpenSceneGraph.build/Debug/uninstall.build/Script-495994A8D09A48648262044A.sh

echo ""

/Applications/CMake.app/Contents/bin/cmake -P /Users/robert/Documents/691/Prototype/build/osg/cmake_uninstall.cmake
CMake Error at cmake_uninstall.cmake:2 (MESSAGE):
Cannot find install manifest:
"/Users/robert/Documents/691/Prototype/build/osg/install_manifest.txt"

make: *** [/Users/robert/Documents/691/Prototype/build/osg/CMakeFiles/uninstall] Error 1
Command /bin/sh failed with exit code 2


Steps to Reproduce:
1) Obtain OpenSceneGraph from http://www.openscenegraph.org/downloads/developer_releases/OpenSceneGraph-3.3.3.zip
2) Use CMake to generate Xcode project (leave all settings at their defaults):
3) Set "Where is the source code" to the directory of the source.
4) Set "Where to build the binaries" to an empty directory.
5) Press Configure button until all red items go away.
6) Press Generate button.
7) Open generated Xcode project in Xcode.
8) Build the Xcode project.


My configuration:
* MacBook Pro (Retina, 15-inch, Early 2013)
* OS X Yosemite 10.10.2
* Xcode Version 6.1.1 (6A2008a)
* CMake 3.1.0

The same build error occurs when cloning from github:
git clone http://github.com/openscenegraph/osg.git

Thanks a bunch for any help!
-Robert Graf
Back to top
View user's profile Send private message
muzzleburst (Robert Graf)
Newbie


Joined: 18 Nov 2014
Posts: 12

PostPosted: Tue Feb 03, 2015 9:58 pm    Post subject:
Reply with quote

Aha, Xcode is trying to build the uninstall scheme first, before all other schemes. It is unable to uninstall because the install scheme has not run yet.

One solution is to disable the uninstall scheme using the Scheme Manager.

It would be nice if the OpenSceneGraph Xcode project generated from CMake built correctly out-of-the-box by simply opening the Xcode project and starting a build, without having to manipulate the schemes initially. This used to work in the past with earlier versions of OpenSceneGraph, if I recall correctly.

Cheers,
-Robert
Back to top
View user's profile Send private message
muzzleburst (Robert Graf)
Newbie


Joined: 18 Nov 2014
Posts: 12

PostPosted: Tue Feb 03, 2015 10:40 pm    Post subject:
Reply with quote

Easiest solution:
Simply activate the ALL_BUILD scheme from the drop-down menu at the top of the window. It defaults to uninstall, which probably is not desirable.

-Robert
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10989

PostPosted: Wed Feb 04, 2015 8:31 am    Post subject:
Xcode: Cannot find install manifest
Reply with quote

HI Robert,

On 3 February 2015 at 22:40, Robert Graf < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Easiest solution:
Simply activate the ALL_BUILD scheme from the drop-down menu at the top of the window. It defaults to uninstall, which probably is not desirable.


I have just checked OpenSceneGraph/CMakeLists.txt and it refers to install before uninstall and my Makefile the install is provided before the uninstall.  I'm not an OSX user let alone an XCode one so can't comment when CMake or XCode might be doing wrong to screw things up, but it looks like at least on the OSG CMake side the isn't anything I've seen so far that would cause this ordering issue.


When I have used OSX I've in the past I've always used the Makefile to build as it's simpler and quicker to do, I found XCode was just made simple things awkward to do. Mostly I would expect OSG users to just want to build and install the OSG so you might well be able to just use the Makefile system.

BTW, you don't need to tell CMake to use Makefiles under unices as this is the default.


Robert.

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
muzzleburst (Robert Graf)
Newbie


Joined: 18 Nov 2014
Posts: 12

PostPosted: Wed Feb 04, 2015 9:15 pm    Post subject:
Reply with quote

Thanks a bunch Robert for checking on this and getting back. The suggestion about avoiding Xcode on OS X is good too. It also is simple enough to make sure the ALL_BUILD scheme is active before running the build.

Thanks again for the help!
-Robert
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts CMake: 3rdPartyPackages - extended to... robertosfield Submission 1 Wed Dec 21, 2016 5:10 pm View latest post
No new posts CMake: 3rdPartyPackages - extended to... zonk Submission 0 Sat Oct 22, 2016 3:20 pm View latest post
No new posts bug: Openscenegraph-3.4 branch instal... remoe General 1 Thu Sep 29, 2016 2:57 pm View latest post
No new posts OSG Build Error on Mac OSX with XCode... ravidavi Build system [build] 4 Mon Jul 18, 2016 6:17 am View latest post
No new posts Could not find plugin to read objects... robertosfield Plugins [osgPlugins] 2 Sat Jul 02, 2016 1:45 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP