OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Build Openscenegraph 3.2.1 in OSX Yosemite


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
dgquvn
Newbie


Joined: 30 Jun 2015
Posts: 2

PostPosted: Tue Jun 30, 2015 9:04 pm    Post subject:
Build Openscenegraph 3.2.1 in OSX Yosemite
Reply with quote

Hi,
I tried to use CMake 3.3.0 to build the source code of OpenSceneGraph 3.2.1 in OSX Yosemite, use Xcode as the generator, but it shows the following msg while configuring.

Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find SDL (missing: SDL_LIBRARY SDL_INCLUDE_DIR)
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find Boost
Could NOT find TIFF (missing: TIFF_LIBRARY TIFF_INCLUDE_DIR)
AVFoundation disabled for SDK < 10.8
Configuring done

Then it comes the list msg for generating,

CMake Warning (dev):
Policy CMP0042 is not set: MACOSX_RPATH is enabled by default. Run "cmake
--help-policy CMP0042" for policy details. Use the cmake_policy command to
set the policy and suppress this warning.

MACOSX_RPATH is not specified for the following targets:

OpenThreads
osg
osgAnimation
osgDB
osgFX
osgGA
osgManipulator
osgParticle
osgPresentation
osgShadow
osgSim
osgTerrain
osgText
osgUtil
osgViewer
osgVolume
osgWidget

This warning is for project developers. Use -Wno-dev to suppress it.

Generating done

What should I do with that? First time to build, please help! Many thanks!!!

Cheers,
Blueze
Back to top
View user's profile Send private message
dgquvn
Newbie


Joined: 30 Jun 2015
Posts: 2

PostPosted: Tue Jul 28, 2015 2:44 pm    Post subject:
Build Openscenegraph 3.2.1 in OSX Yosemite
Reply with quote

Hi,
I tried to use CMake 3.3.0 to build the source code of OpenSceneGraph 3.2.1 in OSX Yosemite, use Xcode as the generator, but it shows the following msg while configuring.

Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find SDL (missing: SDL_LIBRARY SDL_INCLUDE_DIR)
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Could NOT find Boost
Could NOT find TIFF (missing: TIFF_LIBRARY TIFF_INCLUDE_DIR)
AVFoundation disabled for SDK < 10.8
Configuring done

Then it comes the list msg for generating,

CMake Warning (dev):
Policy CMP0042 is not set: MACOSX_RPATH is enabled by default. Run "cmake
--help-policy CMP0042" for policy details. Use the cmake_policy command to
set the policy and suppress this warning.

MACOSX_RPATH is not specified for the following targets:

OpenThreads
osg
osgAnimation
osgDB
osgFX
osgGA
osgManipulator
osgParticle
osgPresentation
osgShadow
osgSim
osgTerrain
osgText
osgUtil
osgViewer
osgVolume
osgWidget

This warning is for project developers. Use -Wno-dev to suppress it.

Generating done

What should I do with that? First time to build, please help! Many thanks!!!

Cheers,
Blueze

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=64226#64226







------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Alberto Luaces
Guest





PostPosted: Tue Jul 28, 2015 2:56 pm    Post subject:
Build Openscenegraph 3.2.1 in OSX Yosemite
Reply with quote

"Blueze Deng" writes:

Quote:
Generating done

Hi Blueze, so far there are no apparent errors. You can proceed
building OSG.

--
Alberto



------------------
Post generated by Mail2Forum
Back to top
jyby
Newbie


Joined: 14 Aug 2015
Posts: 2

PostPosted: Fri Aug 14, 2015 7:20 pm    Post subject:
Reply with quote

Hi,

I've gotten this issue too and then my build stops at 94% and I appear to have an ffmpeg issue.

The the dependencies to build for OS X don't seem to be well documented.

Can you provide a list of what we need and what works to produce successful builds?

Thank you!

Cheers,
Jeffrey
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts OpenSceneGraph static linking for And... tanshihaj Build system [build] 0 Sun Aug 13, 2017 10:09 pm View latest post
No new posts Please test OpenSceneGraph-3.4 in pre... Beatrix General 17 Wed Jul 26, 2017 12:23 pm View latest post
No new posts osgOcean and OpenSceneGraph issue sta... Paradox osgOcean [osgOcean] 0 Tue Jun 20, 2017 10:21 am View latest post
No new posts osgOcean and OpenSceneGraph issue sta... Paradox osgOcean [osgOcean] 0 Tue Jun 20, 2017 10:16 am View latest post
No new posts osgOcean and OpenSceneGraph issue sta... Paradox osgOcean [osgOcean] 0 Tue Jun 20, 2017 10:13 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP