OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Latest VPB with OSG 3.4.0RC5 with VS2013


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb]
View previous topic :: View next topic  
Author Message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Tue Jul 21, 2015 3:35 pm    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hello There,

I was trying to build VPB with the latest OSG on Windows with VS2013 and I got a lot of compiler errors; there's a big chance that latest versions are incompatible. I wanted to check out if it's a platform/compiler issue or not.

Anybody tried that using the latest RC on linux or other platforms?


Thank you!

Cheers,
Can
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10862

PostPosted: Tue Jul 21, 2015 3:37 pm    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hi Can,


Could you provide the build errors so we can work out what might be amiss.


Robert.


On 21 July 2015 at 16:35, Can T. Oguz < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hello There,

I was trying to build VPB with the latest OSG on Windows with VS2013 and I got a lot of compiler errors; there's a big chance that latest versions are incompatible. I wanted to check out if it's a platform/compiler issue or not.

Anybody tried that using the latest RC on linux or other platforms?


Thank you!

Cheers,
Can

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=64389#64389





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Tue Jul 21, 2015 11:10 pm    Post subject:
Reply with quote

Hi Robert,

Thank you for the quick response. I've attached the build log. Please note that this is from 3.4.0 RC1, RC5 is also similar, right now I have access to my other desktop so I'm sending this one to give a quick idea.

Regards,

Can
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10862

PostPosted: Wed Jul 22, 2015 5:22 am    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hi Can,


I have just compiled VPB svn/trunk against OSG svn/trunk under Linux and there are no build errors. This is building with Kubuntu 15.04.


I have looked at your build errors and it looks like VPB isn't building against the latest OSG.  Any chance the CMake configuration for VPB is pointing at an old version of the OSG?


Robert.


On 22 July 2015 at 00:10, Can T. Oguz < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Robert,

Thank you for the quick response. I've attached the build log. Please note that this is from 3.4.0 RC1, RC5 is also similar, right now I have access to my other desktop so I'm sending this one to give a quick idea.

Regards,

Can

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=64391#64391




_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
SMesserschmidt (Sebastian Messerschmidt)
Forum Moderator


Joined: 10 Sep 2013
Posts: 720

PostPosted: Wed Jul 22, 2015 6:38 am    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hi,

Builds on VS2010 with osg-trunk and vpb-master without any problems.
The build errors are really strange.
Something like:
Quote:
error C2039: 'Serializer' : is not a member of 'osgDB'


may indicate that you are pulling in some foreign headers.

I'll check the RC when I've got time

Cheers
Sebastian


Quote:
Quote:
Hi Robert,

Thank you for the quick response. I've attached the build log. Please note that this is from 3.4.0 RC1, RC5 is also similar, right now I have access to my other desktop so I'm sending this one to give a quick idea.

Regards,

Can

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=64391#64391





Quote:
_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Wed Jul 22, 2015 11:52 am    Post subject:
Reply with quote

Hi There,

It turns out that it was an old version of VPB (!) Just checked out the truck folder and now Cmake says:


msvc2010 + build fix /FORCE:MULTIPLE
CMake Error at CMakeLists.txt:318 (INCLUDE):
include could not find load file:

VpbMacroUtils


CMake Error at src/vpb/CMakeLists.txt:81 (LINK_EXTERNAL):
Unknown CMake command "LINK_EXTERNAL".


And yes, VpbMacroUtils is where it should be. It looks like
SET(CMAKE_MODULE_PATH "${VIRTUALPLANETBUILDER_SOURCE_DIR}/CMakeModules;${CMAKE_MODULE_PATH}") command didn't work because FindGDAL was also not overriden.

Any ideas?

Can




Thank you!

Cheers,
Can
Back to top
View user's profile Send private message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Wed Jul 22, 2015 12:28 pm    Post subject:
Reply with quote

I've found out what the problem is:

On CmakeLists.txt line#29, there's a typo:

PROJECT(VitualPlanetBuilder)
Back to top
View user's profile Send private message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Wed Jul 22, 2015 12:52 pm    Post subject:
Reply with quote

No, CMake builds only if I replace references to

VIRTUALPLANETBUILDER_SOURCE_DIR

with

CMAKE_SOURCE_DIR


Now, after this changes, I have new build errors attached Smile

It looks like I needed to add something to disable the checked iterators, so I tried adding

ADD_DEFINITIONS(-D_SECURE_SCL=0)

but it didn't work.

2>gdal.lib(cpl_odbc.obj) : error LNK2019: unresolved external symbol _SQLAllocConnect@8 referenced in function "public: int __thiscall CPLODBCSession::EstablishSession(char const *,char const *,char const *)" (?EstablishSession@CPLODBCSession@@QAEHPBD00@Z)

And what about this?

Thanks,

Can
Back to top
View user's profile Send private message
webmaster
Guest





PostPosted: Wed Jul 22, 2015 1:04 pm    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hi robert,
I ever do the same things in windows 7 x64 and VC2010 some days ago,have no problem,but the compiled VPB can't work properly.
zhuwan
07,22,2015



在2015-7-22 13:21:01,"Robert Osfield" <> 写道:
Quote:
-----原始邮件-----
发件人: "Robert Osfield" <>
发送时间: 2015-7-22 13:21:01
收件人: "OpenSceneGraph Users" <>
主题: Re: [vpb] Latest VPB with OSG 3.4.0RC5 with VS2013

Hi Can,


I have just compiled VPB svn/trunk against OSG svn/trunk under Linux and there are no build errors. This is building with Kubuntu 15.04.


I have looked at your build errors and it looks like VPB isn't building against the latest OSG. Any chance the CMake configuration for VPB is pointing at an old version of the OSG?


Robert.


On 22 July 2015 at 00:10, Can T. Oguz < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Robert,

Thank you for the quick response. I've attached the build log. Please note that this is from 3.4.0 RC1, RC5 is also similar, right now I have access to my other desktop so I'm sending this one to give a quick idea.

Regards,

Can

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=64391#64391




_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org






------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10862

PostPosted: Wed Jul 22, 2015 1:40 pm    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

HI Can,


On 22 July 2015 at 13:28, Can T. Oguz < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
I've found out what the problem is:

On CmakeLists.txt line#29, there's a typo:

PROJECT(VitualPlanetBuilder)


Ooopps.... a typo I introduced this morning when trying to make VPB a bit more consistent.  Now fixed and checked into VPB svn/trunk and VPB-1.0 branch.


Robert.

 

 

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Wed Jul 22, 2015 4:31 pm    Post subject:
Reply with quote

Thanks Robert,

How to disable checked iterators properly? And what to do about SqlAllocConnect error?

Cheers,

Can
Back to top
View user's profile Send private message
ctoguz (Can T. Oguz)
Newbie


Joined: 21 Apr 2011
Posts: 14

PostPosted: Wed Jul 22, 2015 5:17 pm    Post subject:
Reply with quote

News:

Choosing gdal_i.lib instead of gdal.lib solves the problem; i guess it's about linking to static libraries. Now I'll rebuild our terrain models and see if they look ok.

Now two things to declare:

1. "VIRTUALPLANETBUILDER_SOURCE_DIR" to be replaced with "CMAKE_SOURCE_DIR" (or some other tweak to make it build smoothly on VS2013)

2. We need a flag for disabling MSVC checked iterators just as one exists in OSG right now.


I'll be back with good news I guess:)

Regards,

Can
Back to top
View user's profile Send private message
minghia
Appreciator


Joined: 12 Dec 2011
Posts: 104
Location: Sydney, Australia

PostPosted: Fri Sep 11, 2015 8:29 am    Post subject:
Reply with quote

I am trying to build VirtualPlanetBuilder on Centos 6 and I am getting the following errors:

CMake Error at CMakeLists.txt:318 (INCLUDE):
include could not find load file:

VpbMacroUtils



CMake Error at src/vpb/CMakeLists.txt:83 (LINK_EXTERNAL):
Unknown CMake command "LINK_EXTERNAL".

I have take a clean build from the Github mirror and just run "ccmake .". The macro file VpbMacroUtils.cmake is in CMakeModules but for some reason cmake is not finding it. Any suggestions?

_________________
Tony V
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10862

PostPosted: Fri Sep 11, 2015 8:57 am    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hi Tony,


I'm looking into this, currently it looks like a case issue on one of the CMake variables.  I should have a fix checked in soon.


Robert.


On 11 September 2015 at 09:29, Tony Vasile < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
I  am trying to build VirtualPlanetBuilder on Centos 6 and I am getting the following errors:

CMake Error at CMakeLists.txt:318 (INCLUDE):
   include could not find load file:

     VpbMacroUtils



 CMake Error at src/vpb/CMakeLists.txt:83 (LINK_EXTERNAL):
   Unknown CMake command "LINK_EXTERNAL".

I have take a clean build from the Github mirror and just run "ccmake .". The macro file VpbMacroUtils.cmake is in CMakeModules but for some reason cmake is not finding it. Any suggestions?

------------------------
Tony V

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=65113#65113





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10862

PostPosted: Fri Sep 11, 2015 9:17 am    Post subject:
Latest VPB with OSG 3.4.0RC5 with VS2013
Reply with quote

Hi Tony,

On 11 September 2015 at 09:56, Robert Osfield < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
I'm looking into this, currently it looks like a case issue on one of the CMake variables.  I should have a fix checked in soon.



I have tracked down the issue to a change of case of CMake project name from VIRTUALPLANETBUILDER to VirtualPlanetBuilder, this change fixed a branching/tag issue but inadvertently broke the build.  I can't have do a clean cmake . after making the changes last month.  The change in case cased a problem because I didn't spot the need for changing the cmake generated VIRTUALPLANETBUILDER_SOURCE_DIR var usag to VirtualPlanetBuilder_SOURCE_DIR.  Making this later change fixes the cmake issues.


I have check this fix into VPB svn/trunk and the VPB-1.0 branch.



Robert.

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts osg build (master) failed with VS2013... Trajce Nikolov NICK General 1 Thu Feb 09, 2017 2:26 pm View latest post
No new posts Latest OSG cannot realize viewer unde... kornerr General 4 Wed Oct 19, 2016 2:29 pm View latest post
No new posts bug: Openscenegraph-3.4 branch instal... remoe General 1 Thu Sep 29, 2016 2:57 pm View latest post
No new posts the latest info andreas.ekstrand General 0 Fri Sep 16, 2016 5:33 am View latest post
No new posts porting old code to the latest osg is... Trajce Nikolov NICK General 4 Fri Sep 02, 2016 12:11 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP