OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Linker errors when building with OSG_USE_QT


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
skhecht
Newbie


Joined: 18 Jan 2016
Posts: 1

PostPosted: Mon Jan 18, 2016 10:53 pm    Post subject:
Linker errors when building with OSG_USE_QT
Reply with quote

Hi,

I have built OSG with CMake3.4.1 and VS2015 on Windows 10 already, however, I now want to build it to use Qt so I can incorporate it into Qt projects. I check off the OSG_USE_QT variable in CMake (I use the GUI) and generate just fine. However, when I build the solution in VS2015, I get a whole bunch of linker errors for the Qt and Qt-related projects (I was going to post a pastebin link to the errors, but I can't post links here, so here are a few of the errors; there are ~1400 of them):

2>GraphicsWindowQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: __thiscall QMutex::QMutex(enum QMutex::RecursionMode)" (__imp_??0QMutex@@QAE@W4RecursionMode@0@@Z) referenced in function "public: __thiscall osgQt::GLWidget::GLWidget(class QGLFormat const &,class QWidget *,class QGLWidget const *,class QFlags<enum Qt::WindowType>,bool)" (??0GLWidget@osgQt@@QAE@ABVQGLFormat@@PAVQWidget@@PBVQGLWidget@@V?$QFlags@W4WindowType@Qt@@@@_N@Z)
2>GraphicsWindowQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: __thiscall QMutex::~QMutex(void)" (__imp_??1QMutex@@QAE@XZ) referenced in function __unwindfunclet$??0GLWidget@osgQt@@QAE@ABVQGLFormat@@PAVQWidget@@PBVQGLWidget@@V?$QFlags@W4WindowType@Qt@@@@_N@Z$1
2>GraphicsWindowQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: void __thiscall QMutex::lock(void)" (__imp_?lock@QMutex@@QAEXXZ) referenced in function "protected: void __thiscall osgQt::GLWidget::enqueueDeferredEvent(enum QEvent::Type,enum QEvent::Type)" (?enqueueDeferredEvent@GLWidget@osgQt@@IAEXW4Type@QEvent@@0@Z)
2>GraphicsWindowQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: __thiscall QMutexLocker::~QMutexLocker(void)" (__imp_??1QMutexLocker@@QAE@XZ) referenced in function "protected: void __thiscall osgQt::GLWidget::enqueueDeferredEvent(enum QEvent::Type,enum QEvent::Type)" (?enqueueDeferredEvent@GLWidget@osgQt@@IAEXW4Type@QEvent@@0@Z)
2>GraphicsWindowQt.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: __thiscall QByteArray::~QByteArray(void)" (__imp_??1QByteArray@@QAE@XZ) referenced in function "public: static struct osg::GraphicsContext::Traits * __cdecl osgQt::GraphicsWindowQt::createTraits(class QGLWidget const *)" (?createTraits@GraphicsWindowQt@osgQt@@SAPAUTraits@GraphicsContext@osg@@PBVQGLWidget@@@Z)

Any help is greatly appreciated.

Thank you!

Sam
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Building OSG for Android -- Windowing... bwhaines Build system [build] 4 Sun Apr 23, 2017 2:01 am View latest post
No new posts Error building terrain with shapefile... robertosfield VirtualPlanetBuilder [vpb] 0 Mon Feb 06, 2017 9:11 am View latest post
No new posts Error building terrain with shapefile... vinothrajendran4 VirtualPlanetBuilder [vpb] 0 Mon Feb 06, 2017 6:24 am View latest post
No new posts Problem building .dae format file us... vinothrajendran4 VirtualPlanetBuilder [vpb] 4 Wed Jan 18, 2017 12:05 pm View latest post
No new posts Disable FFMpeg while building OSG? jiapei100 Build system [build] 1 Fri Jan 06, 2017 11:36 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP