OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Problem of rendering to texture with two camera


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum]
View previous topic :: View next topic  
Author Message
tsujie
Newbie


Joined: 08 Jan 2016
Posts: 1

PostPosted: Thu Jan 21, 2016 5:25 pm    Post subject:
Problem of rendering to texture with two camera
Reply with quote

Hi,

I have a problem when using two cameras and both of them attach to the same osg::Image as target. My purpose is to blend the results of two cameras(they have different projection and view matrix). But I just get the second camera rendered result. If I don't attach two osg::Image, then the result displayed correctly on screen. For the second camera, I don't clear color, just clear depth. But the background seems always cleared as (0, 0, 0, 0).
...


Thank you!

Cheers,
Jie
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts How to change camera's yaw and pitch,... Rodrigo General [3rdparty] 3 Thu Jan 31, 2019 12:43 am View latest post
No new posts Completely offscreen rendering using ... Waaayoff General 0 Mon Jan 28, 2019 10:06 am View latest post
No new posts setViewMatrixAsLookAt not working to ... Rodrigo General 4 Tue Jan 08, 2019 2:48 am View latest post
No new posts Use PNG as texture for terrain in osg... Rodrigo General [3rdparty] 12 Mon Jan 07, 2019 5:13 pm View latest post
No new posts Scale object based on camera distance Moohasha General 3 Fri Jan 04, 2019 4:57 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP