OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgviewer using one full core


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum]
View previous topic :: View next topic  
Author Message
Paul_
Newbie


Joined: 29 Jan 2016
Posts: 2

PostPosted: Fri Jan 29, 2016 4:20 pm    Post subject:
osgviewer using one full core
Reply with quote

Dear All,

I'm running the following example
Quote:

C:\work\libs\openSceneGraph\OpenSceneGraph-3.4.0\build\bin>osgearth_viewer.exe C:\work\libs\osgEarth\osgearth\tests\gdal_tiff.eart
h --window 50 50 900 700 --sky


This is using one full core on my PC even when idle for a long time or window is reduced. Switch Threading model does not help.

My CPU is a core at 2.8GHz, is this the expected behavior ?

Thanks,

Paul[/quote]
Back to top
View user's profile Send private message
SMesserschmidt (Sebastian Messerschmidt)
Forum Moderator


Joined: 10 Sep 2013
Posts: 799

PostPosted: Fri Feb 05, 2016 7:29 pm    Post subject:
osgviewer using one full core
Reply with quote

Hi Paul,

Do you have VSync disabled? This will cause the renderloop to run as
fast as possible.
Also there is some on-demand frame rendering command, in case you want
more control over the rendering loop.

Cheers
Sebastian

Quote:
Dear All,

I'm running the following example

Quote:

C:\work\libs\openSceneGraph\OpenSceneGraph-3.4.0\build\bin>osgearth_viewer.exe C:\work\libs\osgEarth\osgearth\tests\gdal_tiff.eart
h --window 50 50 900 700 --sky



This is using one full core on my PC even when idle for a long time or window is reduced. Switch Threading model does not help.

My CPU is a core at 2.8GHz, is this the expected behavior ?

Thanks,

Paul


------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=66165#66165






[/quote]


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [forum] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Tiny normals: osgviewer vs osgcomposi... Per Nordqvist General 3 Sun Dec 03, 2017 9:36 pm View latest post
No new posts OSG is unable to create 3.3 core prof... ne0ndrag0n General 5 Sat Jul 22, 2017 4:21 pm View latest post
No new posts problem with shapefile height when lo... vinothrajendran4 General 2 Thu Feb 16, 2017 12:22 pm View latest post
No new posts osgText and GL3.3 core profile Adun General 7 Wed Oct 05, 2016 7:04 am View latest post
No new posts osgViewer::GraphicsWindowEmbedded con... Davide Raccagni Submission 4 Wed Sep 28, 2016 9:19 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP