OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Building OSG 3.4.0 with VS2009, Windows 7, minor issues (fixed)


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
etienne1984
Newbie


Joined: 01 Feb 2016
Posts: 4

PostPosted: Mon Feb 08, 2016 1:12 pm    Post subject:
Building OSG 3.4.0 with VS2009, Windows 7, minor issues (fixed)
Reply with quote

Hi,

I was trying to build OpenSceneGraph 3.4.0 with CMake 3.2.2, Visual Studio 2008 (MSC_VER=1500) on a windows 7 station.

I had following error :

Code:
43>l:\compil_osg\openscenegraph-3.4.0\src\osgplugins\osgjs\JSON_Objects(26) : error C2371: 'int8_t' : redefinition; different basic types
43>        L:\COMPIL_OSG\OpenSceneGraph-3.4.0\include\osg/Types(18) : see declaration of 'int8_t'


Which I fixed in ReaderWriterSTL.cpp :

Code:
#ifndef __OSG_TYPES
#if defined(_WIN32) && !defined(__MINGW32__) && (!defined(_MSC_VER) || _MSC_VER<1600)

typedef unsigned __int8 uint8_t;
typedef unsigned __int16 uint16_t;
typedef unsigned __int32 uint32_t;
typedef signed __int8 int8_t;
typedef signed __int16 int16_t;
typedef signed __int32 int32_t;

#else

#include <stdint.h>

#endif
#endif


First and last line of code were added in the quoted code.
I had to do quite the same fix in JSON_Objects header in order to terminate OSG build.

If this is could be due to a mistake in my configuration, please let me know, otherwise I wanted to share this to the community if you think this should be fixed in trunk.

Cheers,
Etienne

PS I can give more details if you need it.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts OSG on Universal Windows Platform Oneiros General 3 Thu Feb 16, 2017 9:59 am View latest post
No new posts Examples Not Responding; Windows 10 x64 S Senften General 0 Tue Feb 07, 2017 8:37 pm View latest post
No new posts Error building terrain with shapefile... robertosfield VirtualPlanetBuilder [vpb] 0 Mon Feb 06, 2017 9:11 am View latest post
No new posts Error building terrain with shapefile... vinothrajendran4 VirtualPlanetBuilder [vpb] 0 Mon Feb 06, 2017 6:24 am View latest post
No new posts Minor issue with GraphicsWindowWin32.... loopy General 0 Mon Jan 23, 2017 10:18 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP