OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

openScenegraph-3.4 gles plugin broken?


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Submission
View previous topic :: View next topic  
Author Message
Voerman, L.
Guest





PostPosted: Wed Feb 24, 2016 1:08 pm    Post subject:
openScenegraph-3.4 gles plugin broken?
Reply with quote

Hi Robert,I got a compile error on the debug version of the gles plugin in the 3.4 branch, 
OpenSceneGraphsrcosgPluginsglesforsythtriangleorderoptimizer.cpp(138): error C2065: 's_vertexScoresComputed' : undeclared identifier



After examening the code I think the s_vertexCacheScores and s_vertexValenceScores arrays are used while not initialized, due to a pair of "#if 0" lines.


These are not in the git head branch, so i suggest to use the version in git-head in the 3.4 branch as well.
Regards, Laurens.

------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12269

PostPosted: Wed Feb 24, 2016 4:17 pm    Post subject:
openScenegraph-3.4 gles plugin broken?
Reply with quote

Hi Laurens,


A release build warning fix broke the debug build due to an assert...  A fix is now checked into master and 3.4 branch.


Robert


On 24 February 2016 at 13:02, Voerman, L. < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi Robert,I got a compile error on the debug version of the gles plugin in the 3.4 branch, 
OpenSceneGraphsrcosgPluginsglesforsythtriangleorderoptimizer.cpp(138): error C2065: 's_vertexScoresComputed' : undeclared identifier



After examening the code I think the s_vertexCacheScores and s_vertexValenceScores arrays are used while not initialized, due to a pair of "#if 0" lines.


These are not in the git head branch, so i suggest to use the version in git-head in the 3.4 branch as well.
Regards, Laurens.


_______________________________________________
osg-submissions mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-submissions-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Submission All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Force OSG for GLES 2.0 to reenable ve... plamen_t General 4 Tue Jun 11, 2019 11:57 am View latest post
No new posts Problems with dae plugin John Richardson Plugins [osgPlugins] 0 Thu Apr 11, 2019 5:00 pm View latest post
No new posts [PARTIALLY SOLVED] Problems with dae ... Nikkitta Plugins [osgPlugins] 4 Mon Apr 08, 2019 3:51 pm View latest post
No new posts Add search location for textures in F... bbjorn Submission 1 Mon Feb 04, 2019 2:22 pm View latest post
No new posts OpenSceneGraph-3.6.4 release candidat... robertosfield General 6 Sat Jan 26, 2019 7:39 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP