OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Error reading TTF font


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Submission
View previous topic :: View next topic  
Author Message
Davide Raccagni
Guest





PostPosted: Fri Jun 24, 2016 1:55 pm    Post subject:
Error reading TTF font
Reply with quote

Hi All,after last code update, I'm not still able to read TTF font file. I have the same error from the osg examples and from my application:


Error reading file D:Devmsvs2015_64OpenSceneGraph-Datafontstimes.ttf: read error (Could not find plugin to read objects from file "D:Devmsvs2015_64OpenSceneGraph-Datafontstimes.ttf".)



To run the examples, the instructions from http://trac.openscenegraph.org/projects/osg//wiki/Support/UserGuides/Examples has been followed.


The osgdb_freetype.dll is available under osgPlugins-3.5.4


Does anything have been changed?


Continuing the investigation, thanks in advance,
Davide

------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12264

PostPosted: Fri Jun 24, 2016 2:03 pm    Post subject:
Error reading TTF font
Reply with quote

HI Davide,

The only thing changed was moving from using a local FindFreetype.cmae
to relying upon the CMake one. Perhaps the later isn't locating the
freetype headers and libs correctly.

Robert.

On 24 June 2016 at 14:46, Davide Raccagni <> wrote:
Quote:
Hi All,
after last code update, I'm not still able to read TTF font file. I have the
same error from the osg examples and from my application:

Error reading file D:\Dev\msvs2015_64\OpenSceneGraph-Data\fonts\times.ttf:
read error (Could not find plugin to read objects from file
"D:\Dev\msvs2015_64\OpenSceneGraph-Data\fonts\times.ttf".)

To run the examples, the instructions from
http://trac.openscenegraph.org/projects/osg//wiki/Support/UserGuides/Examples
has been followed.

The osgdb_freetype.dll is available under osgPlugins-3.5.4

Does anything have been changed?

Continuing the investigation, thanks in advance,
Davide





------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Davide Raccagni
Guest





PostPosted: Fri Jul 08, 2016 8:34 am    Post subject:
Error reading TTF font
Reply with quote

Hi All,I've solved the issue: from now it is mandatory to set the environment variable:


    OSG_LIBRARY_PATH=plugin folder full path


in order to properly load the plugins.


Regards,
Davide


Il venerdì 24 giugno 2016, Davide Raccagni <[url=javascript:_e(%7B%7D,'cvml','');][/url]> ha scritto:
Quote:
Hi All,after last code update, I'm not still able to read TTF font file. I have the same error from the osg examples and from my application:


Error reading file D:Devmsvs2015_64OpenSceneGraph-Datafontstimes.ttf: read error (Could not find plugin to read objects from file "D:Devmsvs2015_64OpenSceneGraph-Datafontstimes.ttf".)



To run the examples, the instructions from http://trac.openscenegraph.org/projects/osg//wiki/Support/UserGuides/Examples has been followed.


The osgdb_freetype.dll is available under osgPlugins-3.5.4


Does anything have been changed?


Continuing the investigation, thanks in advance,
Davide



------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12264

PostPosted: Fri Jul 08, 2016 9:24 am    Post subject:
Error reading TTF font
Reply with quote

Hi Davide,

On 8 July 2016 at 09:25, Davide Raccagni <> wrote:
Quote:
Hi All,
I've solved the issue: from now it is mandatory to set the environment
variable:

OSG_LIBRARY_PATH=plugin folder full path

in order to properly load the plugins.

It's only required if your other system paths don't include the parent
directory of the plugin directory.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Davide Raccagni
Guest





PostPosted: Sat Jul 09, 2016 12:03 pm    Post subject:
Error reading TTF font
Reply with quote

Hi Robert,that was the way it was working before with my configuration. Both launching from console and VS2015 environment I have the same issue. This is the reason of submission.


Thanks anyway,
Davide

Il venerdì 8 luglio 2016, Davide Raccagni < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> ha scritto:
Quote:
Hi All,I've solved the issue: from now it is mandatory to set the environment variable:


    OSG_LIBRARY_PATH=plugin folder full path


in order to properly load the plugins.


Regards,
Davide


Il venerdì 24 giugno 2016, Davide Raccagni <> ha scritto:
Quote:
Hi All,after last code update, I'm not still able to read TTF font file. I have the same error from the osg examples and from my application:


Error reading file D:Devmsvs2015_64OpenSceneGraph-Datafontstimes.ttf: read error (Could not find plugin to read objects from file "D:Devmsvs2015_64OpenSceneGraph-Datafontstimes.ttf".)



To run the examples, the instructions from http://trac.openscenegraph.org/projects/osg//wiki/Support/UserGuides/Examples has been followed.


The osgdb_freetype.dll is available under osgPlugins-3.5.4


Does anything have been changed?


Continuing the investigation, thanks in advance,
Davide




------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12264

PostPosted: Sat Jul 09, 2016 12:37 pm    Post subject:
Error reading TTF font
Reply with quote

On 9 July 2016 at 12:54, Davide Raccagni <> wrote:
Quote:
Hi Robert,
that was the way it was working before with my configuration. Both launching
from console and VS2015 environment I have the same issue. This is the
reason of submission.

Perhaps you are confusing the language a bit.

A submission is when a member of the OSG community submits code for
inclusion/patch the OSG.

Your emails related to support issue and and appropriate for the
osg-users mailing list/forum.

Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Submission All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts openGL error 'stack overflow' at afte... nebsar General 7 Sun Dec 23, 2018 6:05 am View latest post
No new posts use vs2013 to build osg3.6.3, some er... FreeSouth General 0 Sat Dec 08, 2018 3:26 pm View latest post
No new posts OpenGL viewport error (with Oculus) Riccardo Corsi General 6 Wed Oct 17, 2018 10:44 am View latest post
No new posts [Crash issue] no error info even set ... pwang General 1 Sun Jul 29, 2018 1:20 pm View latest post
No new posts Build error under Windows? Need feedb... robertosfield General 3 Wed Jun 27, 2018 11:11 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP