OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgOcean and osgSim::LOS segmentation fault.


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgOcean [osgOcean]
View previous topic :: View next topic  
Author Message
Paradox
Appreciator


Joined: 19 Apr 2010
Posts: 121

PostPosted: Fri Oct 28, 2016 4:20 pm    Post subject:
osgOcean and osgSim::LOS segmentation fault.
Reply with quote

Hi,

I'm experiencing some problem using LOS with osgOcean. To understand the problem, I have modified the OceanExample inserting a thread which call a series of LOS. There are some strange segmentation fault that speak about LOS intersection visitor and osgOcean main traverse. Is something like that:

Code:

0x00007ffff7748f12 in osg::Geometry::accept(osg::PrimitiveFunctor&) const () from /usr/local/lib/libosg.so.100
(gdb) bt
#0  0x00007ffff7748f12 in osg::Geometry::accept(osg::PrimitiveFunctor&) const () from /usr/local/lib/libosg.so.100
#1  0x00007ffff630a1e1 in osgUtil::LineSegmentIntersector::intersect(osgUtil::IntersectionVisitor&, osg::Drawable*) ()
   from /usr/local/lib/libosgUtil.so.100
#2  0x00007ffff62f1b13 in osgUtil::IntersectorGroup::intersect(osgUtil::IntersectionVisitor&, osg::Drawable*) () from /usr/local/lib/libosgUtil.so.100
#3  0x00007ffff62f19ca in osgUtil::IntersectionVisitor::apply(osg::Geode&) () from /usr/local/lib/libosgUtil.so.100
#4  0x0000000000417d42 in osg::Geode::accept(osg::NodeVisitor&) ()
#5  0x00007ffff7773623 in osg::Group::traverse(osg::NodeVisitor&) () from /usr/local/lib/libosg.so.100
#6  0x00007ffff62f4e30 in osgUtil::IntersectionVisitor::apply(osg::Transform&) () from /usr/local/lib/libosgUtil.so.100
#7  0x00007ffff77e0425 in osg::MatrixTransform::accept(osg::NodeVisitor&) () from /usr/local/lib/libosg.so.100
#8  0x00007ffff7773623 in osg::Group::traverse(osg::NodeVisitor&) () from /usr/local/lib/libosg.so.100
#9  0x00007ffff7b97440 in osgOcean::OceanScene::traverse(osg::NodeVisitor&) () from /usr/local/lib/libosgOcean.so
#10 0x00007ffff62f20b4 in osgUtil::IntersectionVisitor::apply(osg::Group&) () from /usr/local/lib/libosgUtil.so.100
#11 0x00007ffff7b98672 in osg::Group::accept(osg::NodeVisitor&) () from /usr/local/lib/libosgOcean.so
#12 0x00007ffff665827d in osgSim::LineOfSight::computeIntersections(osg::Node*, unsigned int) () from /usr/local/lib/libosgSim.so.100
#13 0x00007ffff6659139 in osgSim::LineOfSight::computeIntersections(osg::Node*, osg::Vec3d const&, osg::Vec3d const&, unsigned int) ()
   from /usr/local/lib/libosgSim.so.100
#14 0x000000000040fd39 in MyThread::run() ()
#15 0x00007ffff6032862 in OpenThreads::ThreadPrivateActions::StartThread(void*) () from /usr/local/lib/libOpenThreads.so.20
#16 0x00007ffff433b184 in start_thread (arg=0x7fffed67a700) at pthread_create.c:312
#17 0x00007ffff554337d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111


Is sufficient to move a little the camera to raise up the problem. Seems to be some side-effect interaction among visitors when ocean make an init() because surface become dirty. Masking the Ocean Surface to the LOS resolves the problem but when we have an object over/under the ocean the problem come up again. Right now I'm not able to fix the problem. Can you addressing me? Maybe a wrong "style" to make that? Example is attached.

Thank you!

Cheers,
Dario
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgOcean [osgOcean] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts How to merge osgocean and osgearth Rambabu General 2 Wed Dec 07, 2016 12:43 pm View latest post
No new posts OsgOcean Rambabu General 1 Mon Nov 28, 2016 11:00 am View latest post
No new posts LOS Intersection and osgOcean segment... Paradox General 1 Wed Sep 14, 2016 10:17 am View latest post
No new posts Custom GraphicsContext Segmentation F... mille25 General 6 Wed Apr 20, 2016 2:46 pm View latest post
No new posts osgSim::GeographicLocation robertosfield General 4 Wed Apr 20, 2016 7:24 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP