OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Problems with .ive loading


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins]
View previous topic :: View next topic  
Author Message
Tiniriel
Newbie


Joined: 02 Sep 2016
Posts: 5

PostPosted: Wed Nov 09, 2016 9:55 am    Post subject:
Problems with .ive loading
Reply with quote

Hi,

I have a problem with osg_ived.dll in 3.4.0 version.

As I'm trying to launch this code to open .ive file
Code:
osg::ref_ptr<osg::Node> model = osgDB::readNodeFile(modelFileName.toStdString());


I get this error in cmd:
Quote:

FindFileInPath() : USING %projectpath%\osgPlugins-3.4.0\osgdb_ived.dll
DynamicLibrary::failed loading "osgPlugins-3.4.0/osgdb_ived.dll"


On version 3.2.2 it worked fine, error occures only in 3.4.0.
Compiler is MSVC 14.0, OS is Win10, project is 32-bit.

Thank you!

Cheers,
Lyubov
Back to top
View user's profile Send private message
Voerman, L.
Guest





PostPosted: Thu Nov 10, 2016 12:59 pm    Post subject:
Problems with .ive loading
Reply with quote

Hi Lyubov,

in your path you have  the unexpanded string "%projectpath%osgPlugins-3.4.0osgdb_ived.dll" - that will not work.
Depending on how and when this is set you need to fix the expansion:


registry keys:
Quote:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerEnvironment Pathor HKEY_CURRENT_USEREnvironment Pathmight have changed from type REG_EXPAND_SZ into REG_SZ by some installer.Or you set it in a bat file before you define projectpath.Regards, Laurens.



On Wed, Nov 9, 2016 at 10:55 AM, Lyubov Akimova < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,

I have a problem with osg_ived.dll in 3.4.0 version.

As I'm trying to launch this code to open .ive file

Code:
osg::ref_ptr<osg::Node> model = osgDB::readNodeFile(modelFileName.toStdString());



I get this error in cmd:

Quote:

FindFileInPath() : USING %projectpath%osgPlugins-3.4.0osgdb_ived.dll
DynamicLibrary::failed loading "osgPlugins-3.4.0/osgdb_ived.dll"


On version 3.2.2 it worked fine, error occures only in 3.4.0.
Compiler is MSVC 14.0, OS is Win10, project is 32-bit.

Thank you!

Cheers,
Lyubov

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=69284#69284





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts [CubeMap with mipmaps] About loading IBL mp3butcher General 3 Sat Nov 04, 2017 12:37 am View latest post
No new posts Dynamical loading of resources robertosfield General 8 Mon Aug 14, 2017 8:15 am View latest post
No new posts Problems with view .FBX files arfaa General 0 Thu Jul 27, 2017 2:48 pm View latest post
No new posts Regarding Slowing loading of building... Rambabu General 2 Fri Apr 21, 2017 7:59 am View latest post
No new posts Forum problems SMesserschmidt General 2 Wed Apr 12, 2017 7:24 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP