OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Fix FBX conversion to OpenGL coordinate system


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Submission
View previous topic :: View next topic  
Author Message
Farshid Lashkari
Guest





PostPosted: Wed Mar 15, 2017 6:34 pm    Post subject:
Fix FBX conversion to OpenGL coordinate system
Reply with quote

Hi Robert,

When the "ZUp" option was added to the fbx loader, it broke the previous behavior of converting to the OpenGL axis system. I'm referencing the following commit:


https://github.com/openscenegraph/OpenSceneGraph/commit/c168887e5e9da4e891904d11ccac8ddd60b0362d



This commit inverted the value of the "fSign" variable, but did not update the previous code that used the variable. I've attached the change that restores the original behavior when not using the "ZUp" option.


Cheers,
Farshid

------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10893

PostPosted: Tue Apr 18, 2017 3:06 pm    Post subject:
Fix FBX conversion to OpenGL coordinate system
Reply with quote

Thanks Farshid, fix merged and submitted to OSG master.

On 15 March 2017 at 18:31, Farshid Lashkari <> wrote:
Quote:
Hi Robert,

When the "ZUp" option was added to the fbx loader, it broke the previous
behavior of converting to the OpenGL axis system. I'm referencing the
following commit:

https://github.com/openscenegraph/OpenSceneGraph/commit/c168887e5e9da4e891904d11ccac8ddd60b0362d

This commit inverted the value of the "fSign" variable, but did not update
the previous code that used the variable. I've attached the change that
restores the original behavior when not using the "ZUp" option.

Cheers,
Farshid





------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Submission All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts osg plugin couldn't load an osgb or i... first_gle General 2 Sat May 27, 2017 3:52 am View latest post
No new posts OpenGL warning qiaokun General 1 Thu May 25, 2017 2:57 am View latest post
No new posts draw primitive sets and geometry shad... wernerM General 0 Wed May 24, 2017 3:20 pm View latest post
No new posts OpenGL error when using TextureBuffer MariusD General 1 Mon May 22, 2017 1:40 pm View latest post
No new posts osg Coordinate system shayne.tueller General 5 Fri Apr 28, 2017 11:54 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP