OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Enable Vertex Attribute Arrays


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Bruno Oliveira
Guest





PostPosted: Mon Mar 20, 2017 1:28 pm    Post subject:
Enable Vertex Attribute Arrays
Reply with quote

Hello,


is there anything I need to do in OSG to enable usage of VertexAttributeArrays?


Like for instance in OpenGL you need to call glEnableVertexAttribArray()
(see https://www.khronos.org/registry/OpenGL-Refpages/es2.0/xhtml/glEnableVertexAttribArray.xml)


I am using OSG 3.4.0 and simply can't make vertex attribute arrays to work

------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 10859

PostPosted: Mon Mar 20, 2017 2:39 pm    Post subject:
Enable Vertex Attribute Arrays
Reply with quote

Hi Bruno,

The OSG will automatically enable vertex attributes when you assign
them to osg::Geometry, there is no need to manually enable anything.

There are range of OSG examples that illustrate vertex attribute array
usage, just do a search for VertexAttrib in OpenSceneGraph/examples/*

Robert.

On 20 March 2017 at 13:25, Bruno Oliveira
<> wrote:
Quote:
Hello,

is there anything I need to do in OSG to enable usage of
VertexAttributeArrays?

Like for instance in OpenGL you need to call glEnableVertexAttribArray()
(see
https://www.khronos.org/registry/OpenGL-Refpages/es2.0/xhtml/glEnableVertexAttribArray.xml)

I am using OSG 3.4.0 and simply can't make vertex attribute arrays to work





------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Scale problem while transforming obje... YuraIU02 General 1 Sat Apr 15, 2017 4:26 pm View latest post
No new posts Using Geometry with packed vertex arrays ravidavi General 2 Sat Mar 25, 2017 4:39 am View latest post
No new posts Setting vertex attribute array of float Bruno Oliveira General 1 Mon Mar 20, 2017 9:55 am View latest post
No new posts Vertex Buffer Object used inside disp... scrawl General 2 Thu Feb 16, 2017 9:14 pm View latest post
No new posts Draw vertex as Circle with color give... Bruno Oliveira General 7 Mon Jan 02, 2017 7:22 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP