OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Limitation of Displaying buildings,roads and trees etc to increase frame rate


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Rambabu
Appreciator


Joined: 10 Nov 2016
Posts: 101

PostPosted: Fri Apr 21, 2017 4:47 am    Post subject:
Limitation of Displaying buildings,roads and trees etc to increase frame rate
Reply with quote

Hi,Actually iam able to displaying the buildings,roads on the terrain using shape files in osgearth,How to display the buildings,roads etc on the desktop screen coordinates only and how can i limit the remaining part where buildings,roads are loading for the purpose of increase of frame rate ?

Iam using osg 3.4.0,osg earth 2.8.0,windows 8.1
Any Help is appreciated.

...

Thank you!

Cheers,
Rambabu
Back to top
View user's profile Send private message
SMesserschmidt (Sebastian Messerschmidt)
Forum Moderator


Joined: 10 Sep 2013
Posts: 799

PostPosted: Fri Apr 21, 2017 8:11 am    Post subject:
Limitation of Displaying buildings, roads and trees etc to increase frame rate
Reply with quote

Hi Rambabu,
Quote:
Hi,Actually iam able to displaying the buildings,roads on the terrain using shape files in osgearth,How to display the buildings,roads etc on the desktop screen coordinates only and how can i limit the remaining part where buildings,roads are loading for the purpose of increase of frame rate ?

Do you mean frustum culling? This already done by OSG. You can limit the
number of items in the scene by using LODs with appropriate distances.
Again: try to put some more effort in describing your problem.

Cheers
Sebastian

Quote:

Iam using osg 3.4.0,osg earth 2.8.0,windows 8.1
Any Help is appreciated.

...

Thank you!

Cheers,
Rambabu

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=70793#70793









------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Displaying the normals of your models SMesserschmidt General 2 Fri Dec 01, 2017 9:18 am View latest post
No new posts measuring a frame Trajce Nikolov NICK General 2 Mon Nov 06, 2017 12:57 am View latest post
No new posts Frame rate improvement Ale General 4 Fri Sep 22, 2017 9:44 am View latest post
No new posts Running a per-frame task on the graph... James Turner General 2 Fri Sep 22, 2017 8:53 am View latest post
No new posts How can I increase the performance? T... gambr General 1 Thu Aug 24, 2017 8:55 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP