OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Crash on Windows 10 with a Display Link adapter


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
efson
Newbie


Joined: 27 Apr 2017
Posts: 2

PostPosted: Thu Apr 27, 2017 9:03 am    Post subject:
Crash on Windows 10 with a Display Link adapter
Reply with quote

Hi,

We have a crash in OSG in the following setup :
- Microsoft Surface Pro 4 with Windows 10.
- Application is displayed on a deported screen using a Display link adapter (Main screen is off).

Crash happens in the module osg130_osg

0:006>
# Call Site
00 osg130_osg!osg::GLBufferObject::GLBufferObject
01 osg130_osg!osg::GLBufferObjectSet::takeOrGenerate
02 osg130_osg!osg::GLBufferObjectManager::generateGLBufferObject
03 osg130_osg!osg::GLBufferObject::createGLBufferObject
04 osg130_osg!osg::BufferObject::getOrCreateGLBufferObject
05 osg130_osg!osg::DrawElementsUShort::draw
06 osgdb_osgearth_engine_mp
07 osgdb_osgearth_engine_mp
08 osg130_osgutil!osgUtil::RenderLeaf::render
09 osg130_osgutil!osgUtil::RenderBin::drawImplementation
0a osg130_osgutil!osgUtil::RenderBin::draw
0b osg130_osgutil!osgUtil::RenderBin::drawImplementation
0c osg130_osgutil!osgUtil::RenderStage::drawImplementation
0d osg130_osgutil!osgUtil::RenderBin::draw
0e osg130_osgutil!osgUtil::RenderStage::drawInner
0f osg130_osgutil!osgUtil::RenderStage::draw
10 osg130_osgutil!osgUtil::SceneView::draw
11 osg130_osgviewer!osgViewer::Renderer::draw
12 osg130_osg!osg::GraphicsContext::runOperations
13 osg130_osg!osg::OperationThread::run
14 osg130_osg!osg::GraphicsThread::run
15 ot20_openthreads!OpenThreads::SetProcessorAffinityOfCurrentThread
16 ucrtbase!invoke_thread_procedure
17 ucrtbase!thread_start<unsigned int (__cdecl*)(void * __ptr64)>
18 kernel32 !BaseThreadInitThunk

We get these error messages : Windows Error #127: [Screen #0] ChooseMatchingPixelFormat() - wglChoosePixelFormatARB extension not found, trying GDI. Reason: The specified procedure could not be found .

Error: OpenGL version test failed, requires valid graphics context.

On other platforms or with the main screen on, we get no error.

Thanks for your help.

Fabien.
Back to top
View user's profile Send private message
Jan Ciger
Guest





PostPosted: Thu Apr 27, 2017 12:16 pm    Post subject:
Crash on Windows 10 with a Display Link adapter
Reply with quote

Hello,

On Thu, Apr 27, 2017 at 11:03 AM, Fabien CLaudot < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,

We have a crash in OSG in the following setup :
-       Microsoft Surface Pro 4 with Windows 10.
-       Application is displayed on a deported screen using a Display link adapter (Main screen is off).

....


 
Quote:
We get these error messages : Windows Error #127: [Screen #0] ChooseMatchingPixelFormat() - wglChoosePixelFormatARB extension not found, trying GDI. Reason: The specified procedure could not be found .

Error: OpenGL version test failed, requires valid graphics context.



 That looks very much like a driver problem. The application failed to create a proper OpenGL context that OSG needs, so the application crashes. The DisplayLink adapters are an external GPU and it may not support OpenGL properly. 


You are not the only one having problems with these adapters and Windows 10:
http://support.displaylink.com/forums/287786-displaylink-feature-suggestions/suggestions/17299984-i-need-full-opengl-support



J.

------------------
Post generated by Mail2Forum
Back to top
efson
Newbie


Joined: 27 Apr 2017
Posts: 2

PostPosted: Thu May 18, 2017 7:48 am    Post subject:
Reply with quote

Hi,

Thank you for your answer.

Fabien.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts MFC mdi child windows show the scene ... rposg General 1 Fri May 26, 2017 6:37 pm View latest post
No new posts OSG crash on startup guyv General 3 Wed Apr 26, 2017 5:07 pm View latest post
No new posts Support for Windows Universal Platform tomhog General 10 Fri Apr 21, 2017 11:07 pm View latest post
No new posts Cross-platform guide for Linux, macOS... kornerr Announcement [ANN] 3 Mon Apr 03, 2017 5:05 pm View latest post
No new posts Vertex Buffer Object used inside disp... scrawl General 2 Thu Feb 16, 2017 9:14 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP