OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osg::Group Child Problem


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Latha Rani
Newbie


Joined: 19 Nov 2016
Posts: 7

PostPosted: Tue Jun 13, 2017 1:16 pm    Post subject:
osg::Group Child Problem
Reply with quote

Hi

in my application i am drawing a quad about 1 kilometer length and 0.1 meters width.i am getting frame rate Around 45 FPS.

Now i am drawing each quad about 1 meter length and .1 meters width,then i am adding all quads to one group node, in this case i am getting frame rate around 25 FPS.

is there any alternative way for drawing all quads of about 1 meter length and 0.1 meters width and adding to scene, for maintaining frame rate about 45 FPS ?

Thank you!

Cheers,
Latha
Back to top
View user's profile Send private message
SMesserschmidt (Sebastian Messerschmidt)
Forum Moderator


Joined: 10 Sep 2013
Posts: 789

PostPosted: Tue Jun 13, 2017 1:42 pm    Post subject:
osg::Group Child Problem
Reply with quote

Hi Latha,

You're most likely measuring your framerate with a debug-build.
Always measure in release-mode! OSG can easily handle tens of thousand
of quads if the scene graph is well balanced.

Cheers
Sebastian

Quote:
Hi

in my application i am drawing a quad about 1 kilometer length and 0.1 meters width.i am getting frame rate Around 45 FPS.

Now i am drawing each quad about 1 meter length and .1 meters width,then i am adding all quads to one group node, in this case i am getting frame rate around 25 FPS.

is there any alternative way for drawing all quads of about 1 meter length and 0.1 meters width and adding to scene, for maintaining frame rate about 45 FPS ?

Thank you!

Cheers,
Latha

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=71042#71042









------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11154

PostPosted: Tue Jun 13, 2017 5:01 pm    Post subject:
osg::Group Child Problem
Reply with quote

HI Latha,

I can't work of what you are specifically trying to achieve and why,
this is important as knowing what problem you are trying to solve is
key to knowing what the best way to solve it is.

I say this as in general most application don't attempt to place very
small geometry elements like quads in their own separate subgraphs,
normally you'd just place them in all a single osg::Geometry. Most
hardware can handle rendering of tens of millions of quads this way.
Have a look at the osgeometry example.

However, I can't say whether just a simple osg::Geometry is sufficient
as you've explain your solution rather than the actual problem.
Please explain what at a high level you are trying to render, i.e. a
road, a cable, etc.

Robert.



Robert.

On 13 June 2017 at 14:16, Latha Rani Baddala <> wrote:
Quote:
Hi

in my application i am drawing a quad about 1 kilometer length and 0.1 meters width.i am getting frame rate Around 45 FPS.

Now i am drawing each quad about 1 meter length and .1 meters width,then i am adding all quads to one group node, in this case i am getting frame rate around 25 FPS.

is there any alternative way for drawing all quads of about 1 meter length and 0.1 meters width and adding to scene, for maintaining frame rate about 45 FPS ?

Thank you!

Cheers,
Latha

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=71042#71042








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Latha Rani
Newbie


Joined: 19 Nov 2016
Posts: 7

PostPosted: Wed Jun 14, 2017 4:28 am    Post subject:
Reply with quote

Hi,

actually i want draw train track in my application. i know track segment points So i want to form a track with quads.distance between points will be about 1meter, So if i want draw a train track of 1 kilometer i have to draw 1000 quads, in this case Frame rate is reducing.if i am drawing one quad of length 1 kilometer frame rate not reducing.

Thank you!

Cheers,
Latha
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11154

PostPosted: Wed Jun 14, 2017 7:49 am    Post subject:
osg::Group Child Problem
Reply with quote

HI Latha,

The standard way to render things like tracks is to create a textured
triangle strip. The texture represents a short section of track and
the texcoord wrap on the geometry is set up to repeat in the direction
of the length of the track.

This approach enables you to keep the vertex count down and also
improves visual quality as texture mipmapping can avoid aliasing that
you'd see if you used separate geometry primitives for each section of
track.

If you really want to get close to the track then displacement mapping
could be used to avoid using geometry. Finally if you need to getting
really close and need geometry to interact with then using LOD's for
close in high res geometry and textured strip for far distances.

Robert.

On 14 June 2017 at 05:28, Latha Rani Baddala <> wrote:
Quote:
Hi,

actually i want draw train track in my application. i know track segment points So i want to form a track with quads.distance between points will be about 1meter, So if i want draw a train track of 1 kilometer i have to draw 1000 quads, in this case Frame rate is reducing.if i am drawing one quad of length 1 kilometer frame rate not reducing.

Thank you!

Cheers,
Latha

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=71045#71045








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Problem compiling OSG 3.4.1 osgDB 64 bit tonyor Build system [build] 0 Thu Sep 21, 2017 12:41 am View latest post
No new posts Problem blending multiple render passes antiro42 General 5 Sat Sep 09, 2017 9:44 am View latest post
No new posts osgText::Text problem robertosfield General 5 Thu Aug 17, 2017 12:23 pm View latest post
No new posts Problem to load images robertosfield General 10 Mon Aug 07, 2017 10:36 pm View latest post
No new posts Multi layer effect rendering problem ... not3not4 General 0 Wed Jul 19, 2017 9:44 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP