OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Problem compiling OSG 3.4.1 osgDB 64 bit


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
tonyor
Newbie


Joined: 21 Sep 2017
Posts: 1

PostPosted: Thu Sep 21, 2017 12:41 am    Post subject:
Problem compiling OSG 3.4.1 osgDB 64 bit
Reply with quote

Hi,

The osgDB solution has as an input lib
C:\OpenSceneGraph\3.4.0\3rdParty\lib\zlib1.lib
That didn't work for me.

Changing the input libs to
C:\OpenSceneGraph\3.4.1\3rdParty\lib\Debug\zlibd.lib
C:\OpenSceneGraph\3.4.1\3rdParty\lib\Release\zlib.lib
as appropriate does work.

Found this problem when updating OSG from 3.4.0 (32 bit) to 3.4.1 (64 bit).
The lib ...\3.4.0\...\zlib1.lib exists but it's not the lib required.

Build configuration was generated by CMake.
Compiler used was VisualStudio 2013

Thank you!

Cheers,
Tony
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts problem with picking/intersecting in ... mue General 0 Sat Jun 09, 2018 11:18 am View latest post
No new posts osgDB::readRefNodeFiles() crashes wit... peter_k General 4 Fri Jun 08, 2018 9:18 am View latest post
No new posts osgText: problem with SCREEN_COORDS mode gwaldron General 9 Thu May 17, 2018 3:56 pm View latest post
No new posts [customizing manipulator] problem wit... mp3butcher General 1 Tue Apr 24, 2018 3:19 pm View latest post
No new posts OSG & QtQuick(QML) & setMirro... karcios General 0 Wed Apr 11, 2018 12:45 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP