OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

createVertexArrayState gives unresolved external symbol


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Andreas Ekstrand
Guest





PostPosted: Fri Dec 01, 2017 1:17 pm    Post subject:
createVertexArrayState gives unresolved external symbol
Reply with quote

Hi,

When linking with 3.5.9 in Visual Studio 2013, I get a an unresolved external symbol for Drawable::createVertexArrayState:

error LNK2001: unresolved external symbol "protected: virtual class osg::VertexArrayState * __cdecl osg::Geometry::createVertexArrayState(class osg::RenderInfo &)const " (?createVertexArrayState@Geometry@osg@@MEBAPEAVVertexArrayState@2@AEAVRenderInfo@2@@Z)

Can't see why though, it's inline but defined properly in base class Drawable header. Does anyone have the same problem or a suggested solution?

/Andreas

------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11357

PostPosted: Fri Dec 01, 2017 1:42 pm    Post subject:
createVertexArrayState gives unresolved external symbol
Reply with quote

Hi Andreas,

Is this linking of the OSG itself. or your application with the OSG?

Robert.

On 1 December 2017 at 13:15, Andreas Ekstrand
<> wrote:
Quote:
Hi,

When linking with 3.5.9 in Visual Studio 2013, I get a an unresolved
external symbol for Drawable::createVertexArrayState:

error LNK2001: unresolved external symbol "protected: virtual class
osg::VertexArrayState * __cdecl osg::Geometry::createVertexArrayState(class
osg::RenderInfo &)const "
(?createVertexArrayState@Geometry@osg@@MEBAPEAVVertexArrayState@2@AEAVRenderInfo@2@@Z)

Can't see why though, it's inline but defined properly in base class
Drawable header. Does anyone have the same problem or a suggested solution?

/Andreas






------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Andreas Ekstrand
Guest





PostPosted: Fri Dec 01, 2017 1:55 pm    Post subject:
createVertexArrayState gives unresolved external symbol
Reply with quote

Hi Robert,

It was in the linking of my application with OSG. But I found the reason just now, I needed to copy the include folder to the build folder for some reason, and didn't update it between 3.5.8 and 3.5.9. So I guess the method had a slight change in its signature. It's fine now, sorry for crying wolf. Smile

/Andreas


On 2017-12-01 14:40, Robert Osfield wrote:

Quote:
Quote:
Hi Andreas,

Is this linking of the OSG itself. or your application with the OSG?

Robert.

On 1 December 2017 at 13:15, Andreas Ekstrand
<> (
Only registered users can see emails on this board!
Get registred or enter the forums!
) wrote:
Quote:
Hi,

When linking with 3.5.9 in Visual Studio 2013, I get a an unresolved
external symbol for Drawable::createVertexArrayState:

error LNK2001: unresolved external symbol "protected: virtual class
osg::VertexArrayState * __cdecl osg::Geometry::createVertexArrayState(class
osg::RenderInfo &)const "
(?createVertexArrayState@Geometry@osg@@MEBAPEAVVertexArrayState@2@AEAVRenderInfo@2@@Z)

Can't see why though, it's inline but defined properly in base class
Drawable header. Does anyone have the same problem or a suggested solution?

/Andreas


_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



------------------
Post generated by Mail2Forum
Back to top
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11357

PostPosted: Fri Dec 01, 2017 3:20 pm    Post subject:
createVertexArrayState gives unresolved external symbol
Reply with quote

Hi Andreas,

On 1 December 2017 at 13:53, Andreas Ekstrand
<> wrote:
Quote:
It was in the linking of my application with OSG. But I found the reason
just now, I needed to copy the include folder to the build folder for some
reason, and didn't update it between 3.5.8 and 3.5.9. So I guess the method
had a slight change in its signature. It's fine now, sorry for crying wolf.
Smile

Thanks for resolving what it was. The ABI changed for 3.5.9 which
explains when updating the headers was required.

Unfortunately a typo in some of the late changes before 3.5.9 means
that I'll need to tag a 3.5.10 quite soon.

Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts [EXTERNAL] Re: Is there a binary dist... Brian Davis General 8 Thu Oct 05, 2017 6:00 pm View latest post
No new posts EXTERNAL: Forum Cary, Karl A. General 1 Wed Jul 12, 2017 3:28 pm View latest post
No new posts Read/write shaders from/to external f... rocco martino Submission 0 Wed Oct 19, 2016 2:02 pm View latest post
No new posts osgversion command fails with symbol ... crubel@compro.net General 4 Tue Oct 11, 2016 5:31 pm View latest post
No new posts Oculus + external view Riccardo Corsi General 1 Wed Jan 20, 2016 12:21 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP