OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

"INSTALL.vcxproj" -- FAILED


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
ceranco (Eran Cohen)
Newbie


Joined: 15 Dec 2017
Posts: 11

PostPosted: Fri Dec 15, 2017 1:25 pm    Post subject:
"INSTALL.vcxproj" -- FAILED
Reply with quote

Hi,

I succeeded in building the OpenScenegraph solution on VS2017 64-bit with the small 3rdParty dependencies, but when I try to build the INSTALL project, it fails with this message:

Quote:

1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: The command "setlocal
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: "C:\Program Files\CMake\bin\cmake.exe" -DBUILD_TYPE=Debug -P cmake_install.cmake
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: if %errorlevel% neq 0 goto :cmEnd
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: :cmEnd
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: :cmErrorLevel
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: exit /b %1
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: :cmDone
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: if %errorlevel% neq 0 goto :VCEnd
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(133,5): error MSB3073: :VCEnd" exited with code 1.
1>Done building project "INSTALL.vcxproj" -- FAILED.


I am using OpenSceneGraph 3.4.1 source files and CMake 3.9.6, but this has happened with CMake 3.10.1 as well.

Thank you!

Cheers,
Eran
Back to top
View user's profile Send private message
ceranco (Eran Cohen)
Newbie


Joined: 15 Dec 2017
Posts: 11

PostPosted: Mon Dec 18, 2017 5:37 pm    Post subject:
Reply with quote

For anyone interested, the build failed because of the place that the Cmake install script looked for the .pdb files of the examples. Cmake looked for them in build/examples/example_name, but all the examples built them to build/bin.
I manually changed the build location for the .pdb file for all of the examples projects to the macro:
Code:
$(ProjectDir)$(AssemblyName)d.pdb
and it fixed the problem.

Cheers,
Eran
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12144

PostPosted: Tue Dec 19, 2017 7:47 am    Post subject:
"INSTALL.vcxproj" -- FAILED
Reply with quote

HI Eran,

Could you post the full modified file or create a PR via github's
openscenegraph repository.

Thanks,
Robert.

On 18 December 2017 at 17:37, Eran Cohen <> wrote:
Quote:
For anyone interested, the build failed because of the place that the Cmake install script looked for the .pdb files of the examples. Cmake looked for them in build/examples/example_name, but all the examples built them to build/bin.
I manually changed the build location for the .pdb file for all of the examples projects to the macro:
Code:
$(ProjectDir)$(AssemblyName)d.pdb

and it fixed the problem.

Cheers,
Eran


------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=72600#72600






[/quote]

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
ceranco (Eran Cohen)
Newbie


Joined: 15 Dec 2017
Posts: 11

PostPosted: Tue Dec 19, 2017 4:09 pm    Post subject:
"INSTALL.vcxproj" -- FAILED
Reply with quote

Hi Robert,

I have no Cmake knowledge, so I didn't change the Cmake script, but rather manually changed the project configurations for all of the examples in visual studio. Right click on the project, select properties. Go to Linker -> Debugging and change the Generate Program Database File to $(ProjectDir)$(AssemblyName)d.pdb

The .vcxproj of the osganalysis example now looks like this:

Quote:

< Link >

< AdditionalDependencies >..\..\lib\osgViewerd.lib;..\..\lib\osgTextd.lib;opengl32.lib;..\..\lib\osgGAd.lib;..\..\lib\osgDBd.lib;C:\Users\ceran\Desktop\OpenSceneGraph-3.4.1\3rdParty\x64\lib\zlibd.lib;..\..\lib\osgUtild.lib;..\..\lib\osgd.lib;..\..\lib\OpenThreadsd.lib;opengl32.lib;kernel32.lib;user32.lib;gdi32.lib;winspool.lib;shell32.lib;ole32.lib;oleaut32.lib;uuid.lib;comdlg32.lib;advapi32.lib< / AdditionalDependencies >
< AdditionalLibraryDirectories >%(AdditionalLibraryDirectories)< / AdditionalLibraryDirectories >
< AdditionalOptions >%(AdditionalOptions) /machine:x64< / AdditionalOptions >
< GenerateDebugInformation >true< / GenerateDebugInformation >
< IgnoreSpecificDefaultLibraries >%(IgnoreSpecificDefaultLibraries)< / IgnoreSpecificDefaultLibraries >
< ImportLibrary >C:/Users/ceran/Desktop/OpenSceneGraph-3.4.1/OpenSceneGraph/build/lib/osganalysisd.lib< / ImportLibrary >
< ProgramDataBaseFile >(ProjectDir)$(AssemblyName)d.pdb< / ProgramDataBaseFile >
< SubSystem >Console< / SubSystem >
< Version >
< / Version >
< / Link >


The line in bold is the line that was changed.

Cheers,
Eran
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12144

PostPosted: Tue Dec 19, 2017 8:54 pm    Post subject:
"INSTALL.vcxproj" -- FAILED
Reply with quote

HI Eran et. al,

Thanks for the info. I don't have Windows expertise so will defer to
members of the community with CMake/Windows expertise to look at this.

Robert.

On 19 December 2017 at 16:09, Eran Cohen <> wrote:
Quote:
Hi Robert,

I have no Cmake knowledge, so I didn't change the Cmake script, but rather manually changed the project configurations for all of the examples in visual studio. Right click on the project, select properties. Go to Linker -> Debugging and change the Generate Program Database File to $(ProjectDir)$(AssemblyName)d.pdb

The .vcxproj of the osganalysis example now looks like this:


Quote:

< Link >

< AdditionalDependencies >..\..\lib\osgViewerd.lib;..\..\lib\osgTextd.lib;opengl32.lib;..\..\lib\osgGAd.lib;..\..\lib\osgDBd.lib;C:\Users\ceran\Desktop\OpenSceneGraph-3.4.1\3rdParty\x64\lib\zlibd.lib;..\..\lib\osgUtild.lib;..\..\lib\osgd.lib;..\..\lib\OpenThreadsd.lib;opengl32.lib;kernel32.lib;user32.lib;gdi32.lib;winspool.lib;shell32.lib;ole32.lib;oleaut32.lib;uuid.lib;comdlg32.lib;advapi32.lib< / AdditionalDependencies >
< AdditionalLibraryDirectories >%(AdditionalLibraryDirectories)< / AdditionalLibraryDirectories >
< AdditionalOptions >%(AdditionalOptions) /machine:x64< / AdditionalOptions >
< GenerateDebugInformation >true< / GenerateDebugInformation >
< IgnoreSpecificDefaultLibraries >%(IgnoreSpecificDefaultLibraries)< / IgnoreSpecificDefaultLibraries >
< ImportLibrary >C:/Users/ceran/Desktop/OpenSceneGraph-3.4.1/OpenSceneGraph/build/lib/osganalysisd.lib< / ImportLibrary >
< ProgramDataBaseFile >(ProjectDir)$(AssemblyName)d.pdb< / ProgramDataBaseFile >
< SubSystem >Console< / SubSystem >
< Version >
< / Version >
< / Link >



The line in bold is the line that was changed.

Cheers,
Eran

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=72608#72608








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
krikr42
Newbie


Joined: 03 May 2018
Posts: 11

PostPosted: Fri May 04, 2018 9:51 am    Post subject:
Re: "INSTALL.vcxproj" -- FAILED
Reply with quote

ceranco wrote:
I have no Cmake knowledge, so I didn't change the Cmake script, but rather manually changed the project configurations for all of the examples in visual studio. Right click on the project, select properties. Go to Linker -> Debugging and change the Generate Program Database File to $(ProjectDir)$(AssemblyName)d.pdb


This worked for me too. If, in Visual Studio, you can mark all the projects in the Examples folder, right-click and select Properties, you can make a bulk-change for the Generate Program Database File property. That way you don't have to make this change for every example separately.
Back to top
View user's profile Send private message
ceranco (Eran Cohen)
Newbie


Joined: 15 Dec 2017
Posts: 11

PostPosted: Fri May 11, 2018 1:29 pm    Post subject:
Reply with quote

This problem seems to have been fixed in the new 3.6.0 release

Cheers,
Eran
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts A question of "ShaderPipeline di... loening General 0 Tue Nov 13, 2018 5:31 pm View latest post
No new posts Moving from 3.4.1 to 3.5.7 breaks my ... loopy General 4 Mon Oct 01, 2018 4:09 pm View latest post
No new posts [Crash issue] no error info even set ... pwang General 1 Sun Jul 29, 2018 1:20 pm View latest post
No new posts Missing OpenThreads PDB when building... guyv Build system [build] 0 Thu Jul 12, 2018 12:39 pm View latest post
No new posts osgQt failed in QT 5.10.1 + osg 3.6 feelapi General [3rdparty] 3 Fri May 11, 2018 12:31 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP