OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

make install_ld_conf does not work n Debian Stretch


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
wartburgritter
Newbie


Joined: 19 Apr 2014
Posts: 7

PostPosted: Fri Dec 22, 2017 7:44 pm    Post subject:
make install_ld_conf does not work n Debian Stretch
Reply with quote

Hi,

I successful compiled OSG. I can use it in my other application if I pass the build and src path to my other application. But if I install it my other application does not find the libraries if I install the application. This seams to be because of this:

The build system is configured to install libraries to /usr/local/lib64
Your applications may not be able to find your installed libraries unless you:
set your LD_LIBRARY_PATH (user specific) or
update your ld.so configuration (system wide)
You have an ld.so.conf.d directory on your system, so if you wish to ensure that
applications find the installed osg libraries, system wide, you could install an
OpenSceneGraph specific ld.so configuration with:
sudo make install_ld_conf

But if I run make install_ld_conf after make install it refuses to do something it says no rule to make "install_ld_conf"

How do I update the ld.so configuration ? Or is it possible just to install osg in the normal lib in /usr/local ?

bernd
Back to top
View user's profile Send private message
wartburgritter
Newbie


Joined: 19 Apr 2014
Posts: 7

PostPosted: Fri Dec 22, 2017 8:39 pm    Post subject:
Reply with quote

Found myself,

- run cmake
- run sudo make install_ld_conf
- run make
- rund sudo make install

with this my new installed application finds the osg libs, but not the findcmake of debian stretch cmake 3.7.2 to build my application. I still use the one from build and src dirs which is cumbersome

bernd
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts How OpenSource make a profit xiaoming General [forum] 1 Tue Jan 16, 2018 1:21 am View latest post
No new posts compile osg on Debian Jessie, after b... wartburgritter Build system [build] 3 Mon Dec 18, 2017 12:24 pm View latest post
No new posts Example with ClipNode not work on iOS xerxses General 1 Wed Dec 06, 2017 9:37 am View latest post
No new posts How to work with zip archives? kornerr General 2 Sat Nov 18, 2017 12:59 pm View latest post
No new posts Make ObjOptionsStruct in obj plugin a... Ralf Habacker Submission 1 Fri Oct 20, 2017 8:31 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP