OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Link error while build plugins


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
gabriella seth
Guest





PostPosted: Tue Jan 09, 2018 12:58 am    Post subject:
Link error while build plugins
Reply with quote

Hi every:


There are some link error while build the plugins:

It somelike Microsoft ODBC, my system is win10 64bit/msvc 2013.
What should i do?


Jieqian
2018/1/8

------------------
Post generated by Mail2Forum
Back to top
mp3butcher (Julien Valentin)
Appreciator


Joined: 17 Feb 2010
Posts: 462
Location: France

PostPosted: Thu Jan 11, 2018 11:46 am    Post subject:
Re: Link error while build plugins
Reply with quote

Hi,
You seams to have problem building gdal plugin...
Which version of osg are you building?
Which 3rdParty package do you use?
(if you're using min depends package perhaps it lacks some libs...)
Cheers

gabriella seth wrote:
Hi every:


There are some link error while build the plugins:

It somelike Microsoft ODBC, my system is win10 64bit/msvc 2013.
What should i do?


Jieqian
2018/1/8

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message Visit poster's website
Trajce Nikolov NICK
Guest





PostPosted: Thu Jan 11, 2018 3:47 pm    Post subject:
Link error while build plugins
Reply with quote

Hi,

I think you should link against gdal_i.lib as I can recall. There are two gdal libs in some of the 3rd party packages


On Thu, Jan 11, 2018 at 12:46 PM, Julien Valentin < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,
You seams to have problem building gdal plugin...
Which version of osg are you building?
What 3rdParty package do you use?
(if you're using min depends package perhaps it lacks some libs...)
Cheers


gabriella seth wrote:
Quote:
Hi every:


There are some link error while build the plugins:

It somelike Microsoft ODBC, my system is win10 64bit/msvc 2013.
What should i do?


Jieqian
2018/1/8

  ------------------
Post generated by Mail2Forum


------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=72727#72727





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




--
trajce nikolov nick

------------------
Post generated by Mail2Forum
Back to top
gabriella seth
Guest





PostPosted: Wed Jan 24, 2018 3:37 am    Post subject:
Link error while build plugins
Reply with quote

Hi,


thanks!


OSG is 3.4.0

The 3rd party packages i'm using is "Full package for 64 bit https://download.osgvisual.org/3rdParty_VS2013.5_v120_x64_V10_full.7z - Last Update: V10 on 2016/10/22"
There are gdal.lib and gdal_i.lib in 3rd party "lib" directory, and i change the value of GDAL_LIBRARY as gdal_i.lib solve that link problem.


Again, the nvtt plugin also has link problem:


From: osg-users <> on behalf of Trajce Nikolov NICK <>
Sent: Thursday, January 11, 2018 3:44 PM
To: OpenSceneGraph Users
Subject: Re: Link error while build plugins

Hi,

I think you should link against gdal_i.lib as I can recall. There are two gdal libs in some of the 3rd party packages


On Thu, Jan 11, 2018 at 12:46 PM, Julien Valentin < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,
You seams to have problem building gdal plugin...
Which version of osg are you building?
What 3rdParty package do you use?
(if you're using min depends package perhaps it lacks some libs...)
Cheers


gabriella seth wrote:
Quote:
Hi every:


There are some link error while build the plugins:

It somelike Microsoft ODBC, my system is win10 64bit/msvc 2013.
What should i do?


Jieqian
2018/1/8



------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=72727#72727





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




--
trajce nikolov nick

------------------
Post generated by Mail2Forum
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts How I build OpenSceneGraph manually f... kornerr General 0 Tue Aug 14, 2018 11:51 am View latest post
No new posts [Crash issue] no error info even set ... pwang General 1 Sun Jul 29, 2018 1:20 pm View latest post
No new posts Android can't build osgdb_png lyn General [forum] 6 Fri Jun 29, 2018 2:35 am View latest post
No new posts Build error under Windows? Need feedb... robertosfield General 3 Wed Jun 27, 2018 11:11 am View latest post
No new posts error while loading .iv file in opens... Rj@123 General 0 Wed Jun 20, 2018 10:52 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP