OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Win 10 + VS17 + OSG 3.2.3 = Failed to read from stream. At osg::Node osgAnimation::AnimationManagerBase


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins]
View previous topic :: View next topic  
Author Message
Paradox
Appreciator


Joined: 19 Apr 2010
Posts: 132

PostPosted: Mon Jan 29, 2018 9:57 am    Post subject:
Win 10 + VS17 + OSG 3.2.3 = Failed to read from stream. At osg::Node osgAnimation::AnimationManagerBase
Reply with quote

Hi,

I'm working on Win 10, compiling OSG 3.2.3 with VS17 using official 3rdparty deps (side note, I have to disable dicom and ktx because errors in headers).

Using SimViewer to open some osgb works fine for all models with NO ANIMATION, but for those with animations I got this error (under linux works fine in both cases!):

InputStream::readObject(): Unsupported wrapper class ì
InputStream: Failed to read from stream. At osg::Node osgAnimation::AnimationManagerBase


Some ideas about the error?

Thank you!

Cheers,
Dario
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12132

PostPosted: Mon Jan 29, 2018 11:29 am    Post subject:
Win 10 + VS17 + OSG 3.2.3 = Failed to read from stream. At osg::Node osgAnimation::AnimationManagerBase
Reply with quote

Hi Dario,

The OSG's binary format is intended to be backwards compatible but
that have been times when this hasn't be possible, sometimes down to
bug fixes, other times perhaps just bugs that are sill lingering,
perhaps the files with animation that you have issues.

I cannot say what these issues might be as I don't have access to the
files that are problematic. Could you post a link to them?

If Linux is working OK perhaps the best thing to do would be to in
linux convert the files to .osgt and newname.osgb and then try these
resulting files under Windows.

Another possible thing to try is OSG-3.4.1.

Robert



On 29 January 2018 at 09:57, Dario Minieri <> wrote:
Quote:
Hi,

I'm working on Win 10, compiling OSG 3.2.3 with VS17 using official 3dparty deps (side note, I have to disable dicom and ktx because errors in headers).

Using SimViewer to open some osgb, works fine for all models with NO ANIMATION, but for those with animations I got this error (under linux works fine in both cases!):

InputStream::readObject(): Unsupported wrapper class ì
InputStream: Failed to read from stream. At osg::Node osgAnimation::AnimationManagerBase

Some ideas about the error?

Thank you!

Cheers,
Dario

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=72882#72882








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
johnhuang
Newbie


Joined: 05 Jul 2018
Posts: 1

PostPosted: Fri Jul 06, 2018 8:50 am    Post subject:
[ Post is awaiting approval ]

[ Post is awaiting approval ]
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Read Image from RTT romulogcerqueira General 6 Thu Sep 27, 2018 7:06 pm View latest post
No new posts update node in view using cullcallback sirian_ye General 2 Wed Aug 29, 2018 11:40 pm View latest post
No new posts Load OSG trimesh to ODE: Read Vertice... TKoller General 2 Fri Jul 20, 2018 3:06 pm View latest post
No new posts Leaking memory on node removal Tini General 1 Fri May 25, 2018 6:48 pm View latest post
No new posts Leaking memory on node removal Tini General 0 Fri May 25, 2018 6:39 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP