OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osg::Geode is not seen when added as child on osgEarth


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
aozdin
Newbie


Joined: 28 Feb 2018
Posts: 16

PostPosted: Wed Feb 28, 2018 1:42 pm    Post subject:
osg::Geode is not seen when added as child on osgEarth
Reply with quote

Hi,
If camera manipulator is EarthManipulator, I can not see my osg::Geode which i draw from the code. How can i put my osg::Geode to the center of osgEarth display? I dont want to place my osg::Node object to any lat/lon/altitude. I want to position my osg::Node to the screen's center whatever lat/lon/altitude is shown on viewpoint.

Thank you!

Cheers,
Ali
Back to top
View user's profile Send private message
aozdin
Newbie


Joined: 28 Feb 2018
Posts: 16

PostPosted: Fri Mar 02, 2018 12:43 pm    Post subject:
Reply with quote

Any idea?
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11909

PostPosted: Fri Mar 02, 2018 4:35 pm    Post subject:
osg::Geode is not seen when added as child on osgEarth
Reply with quote

On 2 March 2018 at 12:43, Ali Ozdin <> wrote:
Quote:
Any idea?

This is an osgEarth question so only users/developers of osgEarth will
be able to provide an answer. Many of the osgEarh community are here
in the main osg-users community as well but perhaps less active on
osgEarth topics than they would be within the osgEarth forum, so if
you don't get a quick answer try there.

Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Having issue with osgText rendering o... pixelord General 0 Mon Apr 16, 2018 4:16 am View latest post
No new posts Qt OsgEarth HudCamera Composition aozdin General 0 Fri Mar 16, 2018 10:34 am View latest post
No new posts How to open shape file (.shp) or open... GISDeveloper General 0 Thu Oct 05, 2017 3:30 pm View latest post
No new posts CullVisitor::apply(Geode&) detect... romulogcerqueira General 7 Wed Aug 30, 2017 3:27 pm View latest post
No new posts osg::Group Child Problem Latha Rani General 4 Tue Jun 13, 2017 1:16 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP