OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Bug with new BaseUniform


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
mp3butcher (Julien Valentin)
Appreciator


Joined: 17 Feb 2010
Posts: 471
Location: France

PostPosted: Fri Mar 30, 2018 12:10 pm    Post subject:
Bug with new BaseUniform
Reply with quote

Hi,

Since I merged with osg master the 03/22, I encountered a bug:
I don't understand it yet but it crashes in optimizer l614 comparing a baseUniform(which should be a uniform) with a uniform.

This silly baseuniform seams to be instanciated via osgb file reading

Will give more lead but if Robert have an idea of what happens it could avoid an other bloody debug session for me

Thank you!

Cheers,
Julien


Last edited by mp3butcher (Julien Valentin) on Sat Mar 31, 2018 12:12 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12094

PostPosted: Fri Mar 30, 2018 12:30 pm    Post subject:
Bug with new BaseUniform
Reply with quote

Hi Julien,

On 30 March 2018 at 13:10, Julien Valentin <> wrote:
Quote:
Since I merged with osg master the 03/22, I encountered a bug:
I don't understand it yet but it crashes in optimizer l614 comparing a baseUniform(which should be a uniform) with a uniform.

This silly baseuniform seams to be instanciated via osgb file reading

Do you mean mean osg::UniformBase? This is a new base class for
uniforms as the old uniform class is a bit of mess of
design/implemention, the UniformBase makes it possible to implement a
range of properly typed uniforms, such as IntUniform, Vec2Uniform etc.

Quote:
Will give more lead but Robert have an idea of what happens it could avoid an other bloody debug session for me

We'll the first thing you need to do if you want help is actually tell
us how to reproduce the problem you are seeing. Also please don't use
the crude language when you do, it's just plain unpleasant to have to
wade through this type of stuff.

Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
mp3butcher (Julien Valentin)
Appreciator


Joined: 17 Feb 2010
Posts: 471
Location: France

PostPosted: Fri Mar 30, 2018 6:02 pm    Post subject:
Re: Bug with new BaseUniform
Reply with quote

trying to isolate min requirement to reproduce I ran in an other bug concerning removeTextureAttribute :
attribute->getTypeMemberPair() is not found for texture bound to other tu than 0.
as TexAttrs are grouped by tu in ss , I believe that TextureAttribute::getMember should be removed(default 0 is good)...
Am I right?

robertosfield wrote:
Hi Julien,

On 30 March 2018 at 13:10, Julien Valentin <> wrote:
Quote:
Since I merged with osg master the 03/22, I encountered a bug:
I don't understand it yet but it crashes in optimizer l614 comparing a baseUniform(which should be a uniform) with a uniform.

This silly baseuniform seams to be instanciated via osgb file reading

Do you mean mean osg::UniformBase? This is a new base class for
uniforms as the old uniform class is a bit of mess of
design/implemention, the UniformBase makes it possible to implement a
range of properly typed uniforms, such as IntUniform, Vec2Uniform etc.

Quote:
Will give more lead but Robert have an idea of what happens it could avoid an other bloody debug session for me

We'll the first thing you need to do if you want help is actually tell
us how to reproduce the problem you are seeing. Also please don't use
the crude language when you do, it's just plain unpleasant to have to
wade through this type of stuff.

Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum



Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP