OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgWidget Visual Studio project is invalid with CMake 3.11.0


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build]
View previous topic :: View next topic  
Author Message
Jiri_Patrak (Jiří Patrák)
Newbie


Joined: 31 Mar 2018
Posts: 1

PostPosted: Sat Mar 31, 2018 4:26 pm    Post subject:
osgWidget Visual Studio project is invalid with CMake 3.11.0
Reply with quote

Maybe this can help somebody or somebody can tell me what I am doing wrong ...

It is not possible to compile Osg with Visual Studio and CMake 3.11.0.

Two months ago i compiled Osg on another machine.

So I generated solution for Visual Studio with CMake 3.9.0 and with CMake 3.11.0.

CMake 3.9.0 generates correct project osgWidget - see 001_ProjectOsgWidgetOK.png.

CMake 3.11.0 generates invalid project osgWidget - see 002_ProjectOsgWidgetNotLoaded.png

Comparison of project files is on the picture 003_OsgWigetProjectsDifference.png

The reason is (I think) the wrong line "CMakelists.txt" - see 004_CMakeListsForOsgWidget.png

I removed the line and after new generating by CMake 3.11.0 is the project correct.

Jiří
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12009

PostPosted: Sun Apr 01, 2018 9:49 am    Post subject:
osgWidget Visual Studio project is invalid with CMake 3.11.0
Reply with quote

Hi Jiří,

That has to be one of the most bizarre errors I've seen in the OSG so
far, amazing it's sat in the code for so long without anyone realizing
it.

I have have removed the stray CMakeLists.txt from the TARGET_SRC and
checked this into OSG master, and the 3.2, 3.4 and 3.6 branches.

Cheers,
Robert.

On 31 March 2018 at 17:26, Jiří Patrák <> wrote:
Quote:
Maybe this can help somebody or somebody can tell me what I am doing wrong ...

It is not possible to compile Osg with Visual Studio and CMake 3.11.0.

Two months ago i compiled Osg on another machine.

So I generated solution for Visual Studio with CMake 3.9.0 and with CMake 3.11.0.

CMake 3.9.0 generates correct project osgWidget - see 001_ProjectOsgWidgetOK.png.

CMake 3.11.0 generates invalid project osgWidget - see 002_ProjectOsgWidgetNotLoaded.png

Comparison of project files is on the picture 003_OsgWigetProjectsDifference.png

The reason is (I think) the wrong line "CMakelists.txt" - see 004_CMakeListsForOsgWidget.png

I removed the line and after new generating by CMake 3.11.0 is the project correct.

Jiří

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=73213#73213




Attachments:
http://forum.openscenegraph.org//files/004_cmakelistsforosgwidget_588.png
http://forum.openscenegraph.org//files/003_osgwigetprojectsdifference_143.png
http://forum.openscenegraph.org//files/002_projectosgwidgetnotloaded_488.png
http://forum.openscenegraph.org//files/001_projectosgwidgetok_182.png





------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Build system [build] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts How to recover osg::ImageStream from ... Andrea74 General 0 Tue Jun 19, 2018 3:47 pm View latest post
No new posts CMake can not find include files peter_k Build system [build] 8 Sun Jun 03, 2018 10:51 am View latest post
No new posts Self provide osg related cmake find_p... Ralf Habacker General 0 Thu Apr 26, 2018 7:11 am View latest post
No new posts Messages when trying to cmake of OSX ... minghia Build system [build] 0 Sat Apr 21, 2018 1:49 pm View latest post
No new posts Memory problems in Windows/Visual Studio markja General 6 Thu Apr 19, 2018 3:20 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP