OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgQt scenegraph flickering with multiple views


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Meldryt
User


Joined: 02 Mar 2016
Posts: 60

PostPosted: Tue May 29, 2018 3:04 pm    Post subject:
osgQt scenegraph flickering with multiple views
Reply with quote

After i have finished moving my gui code from osg to qt,
i noticed a strange render bug in my scene.
Basically i have a compositeviewer with two views,
each view has a GLWidget/QWidget like in the osgviewerQt example.
osgViewer and Qt each run in separate thread.

The first view contains also my osg models.
When i create and add the second view to the compositeviewer,
some models and textures of the scene start to flicker.

edit:

My second view/widget is in an extra window.

No blinking with threadingmodel SingleThreaded.

_________________
OSG Version: 3.4.1
OS: OpenSuse Leap 42.1
Back to top
View user's profile Send private message
Meldryt
User


Joined: 02 Mar 2016
Posts: 60

PostPosted: Wed Jun 20, 2018 3:16 pm    Post subject:
Reply with quote

Flickering actually means that culling is not working correctly for parts of the geometry which overlapping each other in the scene.

Another thing is, if i toggle the StatsHandler in the first view and add the second view the StatsHandler frame is resizing and moving to the middle of the window.

edit:
The flickering is only happening on the window region that is covered by my second window based on origin (0,0).
So it looks like that resizing the second view is affecting the viewport of the first view.
qt widgets are not affected.

Maybe the same bug described here:
http://forum.openscenegraph.org/viewtopic.php?t=8263&postdays=0&postorder=asc&start=0

I don't want to switch osgQt or osg version yet, is there any chance to catch this event?

edit2:
No flickering when i use different values for setting the draw&readbuffer of my main view (GL_BACK) and second view (GL_FRONT).

_________________
OSG Version: 3.4.1
OS: OpenSuse Leap 42.1
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Render multiple PRE_RENDER cameras to... ivar General 3 Tue Nov 13, 2018 3:41 pm View latest post
No new posts Rendering multiple screens njr3 General 1 Wed Oct 31, 2018 8:46 pm View latest post
No new posts CompositeViewer with multiple view, a... Angel General 3 Tue Aug 28, 2018 1:15 pm View latest post
No new posts osgQt include files Michael W. Hall General 142 Sat Aug 11, 2018 9:14 pm View latest post
No new posts osgQt + OSG 3.6.2 Status DeadParrot General 28 Sat Jul 14, 2018 4:38 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP