OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Build error under Windows? Need feedback from Windows users to understand issue


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 11973

PostPosted: Wed Jun 27, 2018 11:11 am    Post subject:
Build error under Windows? Need feedback from Windows users to understand issue
Reply with quote

Hi All,

A PR has just been placed on the openscenegraph github repository:

https://github.com/openscenegraph/OpenSceneGraph/pull/567

I am bit surprised by the need for this PR as I had assumed that the
code base was being rested pretty well under Windows with all the
recent stable release work.

I have asked for the author of the PR for clarification.

I would like to know form the Windows experts in the community about
whether this PR is perfectly fine, or there is some simpler resolution
for this users build combination.

As I'm about to make a 3.6.2 I obviously want the code base to be in
place where it's compiling well for a broad range of users, I'm also
keenly aware that a build fix for one user could be a build break for
many others so am super cautious at this point in time.

Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Daniel Emminizer, Code...
Guest





PostPosted: Wed Jun 27, 2018 11:33 am    Post subject:
Build error under Windows? Need feedback from Windows users to understand issue
Reply with quote

Hi Robert,

I can vouch that it compiles on MSVC 2015, MSVC 2010, and g++ 4.4. I did not test 2012 or 2013, since I figured 2010 and 2015 ought to cover (2015 is _MSC_VER 1900). I only tested 64 bit variants. I do not have MSVC 2017 to test against.

I am also not familiar with the code in question, and we don't directly use the osga plugin in our software so I'm not sure how to test beyond ensuring that it compiles. So it does compile and doesn't break my system, that I can tell.

Hope this helps some.

- Dan


Quote:
-----Original Message-----
From: osg-users [mailto:] On
Behalf Of Robert Osfield
Sent: Wednesday, June 27, 2018 7:11 AM
To: OpenSceneGraph Users
Subject: Build error under Windows? Need feedback from
Windows users to understand issue

Hi All,

A PR has just been placed on the openscenegraph github repository:

https://github.com/openscenegraph/OpenSceneGraph/pull/567

I am bit surprised by the need for this PR as I had assumed that the
code base was being rested pretty well under Windows with all the
recent stable release work.

I have asked for the author of the PR for clarification.

I would like to know form the Windows experts in the community about
whether this PR is perfectly fine, or there is some simpler resolution
for this users build combination.

As I'm about to make a 3.6.2 I obviously want the code base to be in
place where it's compiling well for a broad range of users, I'm also
keenly aware that a build fix for one user could be a build break for
many others so am super cautious at this point in time.

Robert.



------------------
Post generated by Mail2Forum
Back to top
bbjorn
Appreciator


Joined: 12 Oct 2010
Posts: 219
Location: Linköping, Sweden

PostPosted: Wed Jun 27, 2018 11:48 am    Post subject:
Reply with quote

Hi Robert,

I have previously built it using Visual Studio 2017 without problems.

One thing to note is that the user who opened the pull request says he is using Visual Studio version 15.8. This is a version not yet available outside the beta program. The latest stable version available for me is 15.7.4. This might be the reason for his compiler error and also why no one have reported this earlier.

Regards,
Björn
Back to top
View user's profile Send private message Visit poster's website
L. Voerman
Guest





PostPosted: Wed Jun 27, 2018 12:55 pm    Post subject:
Build error under Windows? Need feedback from Windows users to understand issue
Reply with quote

I just updated VS2017 15.7.3 to 15.7.4 and this still compiles just fine.The entire piece of code worries me, as the position is subtracted from the offset and then just added again.
Laurens.


On Wed, Jun 27, 2018 at 1:48 PM Björn Blissing < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:

Quote:
Hi Robert,

I have previously built it using Visual Studio 2017 without problems.

One thing to note is that the user who opened the pull request says he is using Visual Studio version 15.8. This is a version not yet available outside the beta program. The latest stable version available for me is 15.7.4. This might be the reason for his compiler error and also why no one have reported this earlier.

Regards,
Björn

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=74189#74189





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts osglight demo problems with Intel gra... eventhorizon5 General 2 Mon Jul 09, 2018 8:52 pm View latest post
No new posts Android can't build osgdb_png lyn General [forum] 6 Fri Jun 29, 2018 2:35 am View latest post
No new posts error while loading .iv file in opens... Rj@123 General 0 Wed Jun 20, 2018 10:52 am View latest post
No new posts Can't build OSG 2.8.2 on CentOS 7.5 pau Build system [build] 7 Tue Jun 12, 2018 8:50 am View latest post
No new posts Where can i find the windows binaries peter_k General 2 Thu May 31, 2018 12:19 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP