OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgOcean - Render to Texture Camera


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgOcean [osgOcean]
View previous topic :: View next topic  
Author Message
rob_ewbank
Newbie


Joined: 04 Jul 2018
Posts: 2

PostPosted: Wed Jul 04, 2018 11:27 am    Post subject:
osgOcean - Render to Texture Camera
Reply with quote

Hi,

I'm building an interactive projection mapping using osgOcean to simulate the sea, for this I need to render to texture. The RTT camera I'm using works fine on other scenes, however, when using osgOcean, it does not render properly: see attached images.

I've tried setting the render order to pre, nested and post, none of these work. When using a slave camera rather than main I get the results in images, without that it's even worse.

Changing glare on the scene seems to have a big impact on the result and I've tried turning on / off all other features, such as reflection, refraction, etc. with no luck.

What steps should I take in order to successfully render this scene to texture?


Thank you!

Cheers,
Rob
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12094

PostPosted: Mon Jul 09, 2018 9:10 am    Post subject:
osgOcean - Render to Texture Camera
Reply with quote

Hi Rob,

I am afraid that osgOcean is a 3rd party NodeKit that was written a
long time ago and as far as I'm aware has seen active development or
widespread use across the OSG community, so the chances of having
others that have the knowledge to help will be quite low. I don't
know if the original authors are still active, they would be the best
ones to ask.

It might be that if you want to use osgOcean you'll need to work how
it works and maintain it yourself.

Best of luck,
Robert.
On Fri, 6 Jul 2018 at 13:44, Rob Ewbank <> wrote:
Quote:

Hi,

I'm building an interactive projection mapping using osgOcean to simulate the sea, for this I need to render to texture. The RTT camera I'm using works fine on other scenes, however, when using osgOcean, it does not render properly: see attached images.

I've tried setting the render order to pre, nested and post, none of these work. When using a slave camera rather than main I get the results in images, without that it's even worse.

Changing glare on the scene seems to have a big impact on the result and I've tried turning on / off all other features, such as reflection, refraction, etc. with no luck.

What steps should I take in order to successfully render this scene to texture?


Thank you!

Cheers,
Rob

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=74256#74256




Attachments:
http://forum.openscenegraph.org//files/ocean_rtt_glare_130.png
http://forum.openscenegraph.org//files/ocean_rtt_no_glare_110.png





------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
rob_ewbank
Newbie


Joined: 04 Jul 2018
Posts: 2

PostPosted: Wed Jul 11, 2018 10:33 pm    Post subject:
Reply with quote

Thanks Robert, I have been looking through the code and have merged two branches, one which has been changed to work with OSG 3.4.1 and the master.

Osgocean seems to do a few weird tricks with shaders and rendering that cause issues in places such as transparency, when it works, its really nice.

Do you know if the author kbale has been around these parts lately?

This should prob be in another post, but anyway. When using the primitives such as sphere, box etc in OSG 3.6 they don't respond to changing position, size etc. Works fine in 3.4.

Love the framework, I'll post some pics of some of the stuff we're using it for.
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12094

PostPosted: Thu Jul 12, 2018 8:35 am    Post subject:
osgOcean - Render to Texture Camera
Reply with quote

On Wed, 11 Jul 2018 at 23:39, Rob Ewbank <> wrote:
Quote:

Thanks Robert, I have been looking through the code and have merged two branches, one which has been changed to work with OSG 3.4.1 and the master.

Osgocean seems to do a few weird tricks with shaders and rendering that cause issues in places such as transparency, when it works, its really nice.

Do you know if the author kbale has been around these parts lately?

I haven't seen him post for quite a few years. I believe osgOcean was
related to a university research project, folk move on.

Quote:
This should prob be in another post, but anyway. When using the primitives such as sphere, box etc in OSG 3.6 they don't respond to changing position, size etc. Works fine in 3.4.

In 3.6 the osg::ShapeDrawable is now implemented as an osg::Geometry,
broadly it should work the same, if there is a usage case that it
isn't working the same could you create a small test example (such as
modifying an existing OSG example) to illustrate the problem, it could
well be a bug that we can fix once we know what might be amiss.

Cheers,
Robert.


------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgOcean [osgOcean] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Rend to Texture Once GuiYe General 1 Sun Aug 26, 2018 7:31 am View latest post
No new posts Can't share Texture among several tex... mp3butcher General 1 Fri Aug 17, 2018 11:06 pm View latest post
No new posts minor change: move assumeSizedInterna... mp3butcher General 9 Wed Aug 15, 2018 10:07 pm View latest post
No new posts Minor change proposal : Blacklist usa... mp3butcher General 14 Mon Aug 13, 2018 1:42 pm View latest post
No new posts Load an obj file and mapping a given ... aaa3d General 3 Mon Aug 06, 2018 2:27 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP