OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osglight demo problems with Intel graphics on Windows


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
eventhorizon5
Newbie


Joined: 06 Jul 2018
Posts: 6

PostPosted: Mon Jul 09, 2018 8:52 pm    Post subject:
osglight demo problems with Intel graphics on Windows
Reply with quote

I recently started a project based on the osglight demo. I have a laptop with switchable graphics, and under Linux the demo works great under both Intel and Nvidia graphics. Under Windows 10 however, lighting doesn't appear to work with the Intel driver, even though it works fine in Linux (bad drivers?). The console also outputs this:

Quote:

Screen 0:
Vendor: Intel
Renderer: Intel(R) HD Graphics 3000
GL Version: 3.1.0 - Build 9.17.10.4459
Warning: detected OpenGL error 'invalid enumerant' at After Renderer::compile

which implies that the app is using shaders. I thought that the OSG lights used the FFP OpenGL lights and not shaders.

I'm attaching a screenshot of the project.

Ryan
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12144

PostPosted: Tue Jul 10, 2018 5:21 am    Post subject:
osglight demo problems with Intel graphics on Windows
Reply with quote

Hi Ryan,

The osglight example just just the fixed function pipeline and doesn't
provide any shaders.

What you describe sounds like an Intel driver bug. The best thing you
can do is check for latest Intel drivers.

Robert.
On Mon, 9 Jul 2018 at 21:51, Ryan Thoryk <> wrote:
Quote:

I recently started a project based on the osglight demo. I have a laptop with switchable graphics, and under Linux the demo works great under both Intel and Nvidia graphics. Under Windows 10 however, lighting doesn't appear to work with the Intel driver, even though it works fine in Linux (bad drivers?). The console also outputs this:


Quote:

Screen 0:
Vendor: Intel
Renderer: Intel(R) HD Graphics 3000
GL Version: 3.1.0 - Build 9.17.10.4459
Warning: detected OpenGL error 'invalid enumerant' at After Renderer::compile


which implies that the app is using shaders. I thought that the OSG lights used the FFP OpenGL lights and not shaders.

I'm attaching a screenshot of the project.

Ryan

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=74296#74296




Attachments:
http://forum.openscenegraph.org//files/lightmod_173.png





------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
eventhorizon5
Newbie


Joined: 06 Jul 2018
Posts: 6

PostPosted: Thu Jul 12, 2018 10:31 pm    Post subject:
Re: osglight demo problems with Intel graphics on Windows
Reply with quote

robertosfield wrote:

What you describe sounds like an Intel driver bug. The best thing you
can do is check for latest Intel drivers.


I checked over some things and found that the FFP was removed in GL 3.1, and that the Intel driver is reporting as that version. I tested on an older laptop with Intel graphics, and it works, reporting as version 2.1. Linux works and is using GL 3.0. I'm wondering if 3.1 is what the problem is.

Ryan
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts some osgOcean problems Liyanru101 osgOcean [osgOcean] 0 Fri Nov 16, 2018 3:55 am View latest post
No new posts Unable to run example (QTCreator, CMa... Nirodha General [forum] 1 Wed Oct 31, 2018 11:04 pm View latest post
No new posts OSG 3.6.3 Windows VC++ Binaries Posted DeadParrot Announcement [ANN] 3 Mon Oct 29, 2018 8:48 pm View latest post
No new posts Problems with forum. poweruserm@live.com.au General 1 Sun Oct 28, 2018 11:45 pm View latest post
No new posts Problems porting from osg-3.4.0 to os... hvarma General 10 Wed Sep 12, 2018 3:29 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP