OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Enable Qt5Widgets_DIR into cmake (GUI)


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Andrea74
User


Joined: 24 Aug 2009
Posts: 78

PostPosted: Wed Sep 05, 2018 7:40 am    Post subject:
Enable Qt5Widgets_DIR into cmake (GUI)
Reply with quote

Dear all,
i would like to enable Qt5 form Cmake(GUI) 3.8.2 using OSG 3.5.3 on Windows10. I installed QT 5.8.0 in c:\QT\... and i set environment variable QTDIR to C:\Qt\Qt5.8.0\5.8\msvc2013_64

My focus consits in get osgQtBrowser and osgQtWidgets example projects in osg solutions (visual studio 2013).

What i get is:

Ungrouped Entries-> Qt5Widgets_DIR = Qt5Widgets_DIR-NOTFOUND

Furthermore, several QT -> items are automatically filled with NOFOUND (after Configure process). I must manually fill each items!!!

Is there a way to tell CMAKE to fill all qt entries automatically?

Thank you in advance

Regards

Andrea



...

Thank you!

Cheers,
Andrea
Back to top
View user's profile Send private message
Konstantin Podsvirov
Guest





PostPosted: Wed Sep 05, 2018 7:48 am    Post subject:
Enable Qt5Widgets_DIR into cmake (GUI)
Reply with quote

Hello Andrea,10:39, 5 September 2018 г., Andrea Martini <>:
Quote:

Dear all,i would like to enable Qt5 form Cmake(GUI) 3.8.2 using OSG 3.5.3 on Windows10. I installed QT 5.8.0 in c:QT... and i set environment variable QTDIR to C:QtQt5.8.05.8msvc2013_64My focus consits in get osgQtBrowser and osgQtWidgets example projects in osg solutions (visual studio 2013).What i get is:Ungrouped Entries-> Qt5Widgets_DIR = Qt5Widgets_DIR-NOTFOUNDFurthermore, several QT -> items are automatically filled with NOFOUND (after Configure process). I must manually fill each items!!!Is there a way to tell CMAKE to fill all qt entries automatically?Thank you in advanceRegardsAndrea... Thank you!Cheers,Andrea
Just add C:QtQt5.8.05.8msvc2013_64 to CMAKE_PREFIX_PATH variable.

------------------
Post generated by Mail2Forum
Back to top
Andrea74
User


Joined: 24 Aug 2009
Posts: 78

PostPosted: Wed Sep 05, 2018 8:51 am    Post subject:
Reply with quote

Hello Konstatine,
thank you for your suggestion.
Now CMAKE fills all Qt entries automatically.

But, osgQtWidgets and osgQtBrowser aren't in .sln
Looking into mypath\OpenSceneGraph-3.5.3\examples\CMakeLists.txt i found:

...
IF ( (QT4_FOUND AND QT_QTWEBKIT_FOUND) OR Qt5WebKitWidgets_FOUND )
ADD_SUBDIRECTORY(osgQtWidgets)
ADD_SUBDIRECTORY(osgQtBrowser)
ENDIF()
...

Infact, CMAKE (GUI) fill Qt5WebKitWidgets_DIR with Qt5WebKitWidgets_DIR-NOTFOUND. I searched in C:\Qt\Qt5.8.0\5.8\msvc2013_64\lib\cmake and folder Qt5WebKitWidgets is absent.

This is the reason i can't find osgQtWidgets and osgQtBrowser projects in the solution.

I will try with a suggestion on :
https://stackoverflow.com/questions/49249355/could-not-find-qt5webkitwidgets

using qt 5.5 instead of 5.8


Thank you!

Cheers,
Andrea
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Unable to run example (QTCreator, CMa... Nirodha General [forum] 1 Wed Oct 31, 2018 11:04 pm View latest post
No new posts CMake can not find include files peter_k Build system [build] 8 Sun Jun 03, 2018 10:51 am View latest post
No new posts Self provide osg related cmake find_p... Ralf Habacker General 0 Thu Apr 26, 2018 7:11 am View latest post
No new posts Messages when trying to cmake of OSX ... minghia Build system [build] 0 Sat Apr 21, 2018 1:49 pm View latest post
No new posts osgWidget Visual Studio project is in... Jiri_Patrak Build system [build] 1 Sat Mar 31, 2018 4:26 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP