OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Idea to implement a kind of 'rubber mode'

Goto page Previous  1, 2
 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Voerman, L.
Guest





PostPosted: Thu Sep 13, 2018 8:27 am    Post subject:
Idea to implement a kind of 'rubber mode'
Reply with quote

Hi Christoph,I can combine this with a scene that uses shaders without modification. If that's not working for you I don't understand why. 
Using the depth buffer to block further rendering will need the GL_DEPTH_TEST to be active, did that change for your shader/fixed scene?
Laurens.


On Thu, Sep 13, 2018 at 9:59 AM Christoph Dohmen < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:

Quote:
Hi Laurens,

it's working if I reduce the current drawing sources to fixed function pipeline. But unfortunately we use several shaders. As far as I understand the idea, I will need to access the ColorMask from within the fragment shader, right? Any hints for that or am I totally wrong?

Thank you!

Cheers,
Christoph

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=74736#74736





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
christoph
Newbie


Joined: 10 Jul 2014
Posts: 15

PostPosted: Wed Oct 31, 2018 10:40 am    Post subject:
Reply with quote

Hi Laurens,

in the end it took some time but finally I could create source to create the eraser and it is up and running quite smooth. Thank you!

Thank you!

Cheers,
Christoph
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts osgText: problem with SCREEN_COORDS mode gwaldron General 9 Thu May 17, 2018 3:56 pm View latest post
No new posts set cullface mode in osg file Meldryt General 1 Fri Mar 02, 2018 10:07 am View latest post
No new posts Idea about shadows wernerM General 1 Wed Sep 06, 2017 8:55 am View latest post
No new posts wireframe mode and degenerate triangles cbuchner1 General 1 Fri Dec 30, 2016 1:39 pm View latest post
No new posts How to implement pagedLOD without rea... wernerM General 7 Wed Nov 09, 2016 11:47 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP