OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osg3.6.3 plugin issues


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins]
View previous topic :: View next topic  
Author Message
jaisingla
Newbie


Joined: 01 Feb 2017
Posts: 12

PostPosted: Thu Oct 18, 2018 6:35 am    Post subject:
osg3.6.3 plugin issues
Reply with quote

Hi,

I have built osg3.6.3 with VS2017 15.8.3 and newer dependencies
https://download.osgvisual.org/3rdParty_VS2017_v141_x64_V11_small.7z

and it is successfully built. but, osgviewer --image *.png, *.tiff etc. does not work and give read error?? pls help


...

Thank you!

Cheers,
Jai
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12145

PostPosted: Thu Oct 18, 2018 9:27 am    Post subject:
osg3.6.3 plugin issues
Reply with quote

On Thu, 18 Oct 2018 at 08:10, Jai Singla < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
I have built osg3.6.3 with VS2017 and newer dependencies
https://download.osgvisual.org/3rdParty_VS2017_v141_x64_V11_small.7z

and it is successfully built. but, osgviewer --image *.png, *.tiff etc. does not work ?? pls help   


I'm not a Windows user so can't comment on platform specifics, I can provide some general pointers.


First up, check whether your build has built the plugins - there should a bin/osgPlugins-3.6.3 directory (it might be lib/osgPlugins-3.6.3) containing dll's in the form of osgdb_*.dll, this should contain the osgdb_png.dll if the png plugin compiled.


If the plugin has built then it's likely that the you haven't installed the OSG's built libs and dll's or haven't set a path to directory that osgPlugins-3.6.3 is installed to so that the OSG can find them.  I think it's PATH env var under Windows is used to point where to search (it's a few years since I touched Windows.)



To help find where the OSG is looking set the env var OSG_NOTIFY_LEVEL to INFO and then have a look at the console output.  This might help show you where it's looking.



Robert.

------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
sdef
Newbie


Joined: 25 Oct 2018
Posts: 4

PostPosted: Mon Nov 12, 2018 5:59 am    Post subject:
png plugin not found
Reply with quote

Hi,

While building my Flightgear 2017.3.0 with OSG 3.4.0 in eclipse IDE , failed to load png files.

the log contents are below,

view:3:../src/Viewer/splash.cxx:679:Splash screen progress finalize-position
io:4:../src/simgear/scene/model/ModelRegistry.cxx:204:Image loading failed:Warning: Could not find plugin to read objects from file "/usr/local/share/FlightGear/Textures/Sky/moon.png".
opengl:4:../src/Viewer/fg_os_osgviewer.cxx:211:Warning: Could not find plugin to read objects from file "/usr/local/share/FlightGear/Textures/Sky/moon.png".


Please suggest solutions..
...

Thank you!

Cheers,
Rajani
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> Plugins [osgPlugins] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Could not find plugin to load objects sdef General [3rdparty] 1 Sat Oct 27, 2018 6:10 am View latest post
No new posts building the fbx plugin Tare Plugins [osgPlugins] 2 Wed Oct 10, 2018 3:04 pm View latest post
No new posts TIFF plugin reader does not handle im... Eric Sokolowsky Submission 0 Sat Sep 29, 2018 2:30 am View latest post
No new posts issues compiling 3.0.1 Lonnie.CTR.Souder General 2 Wed Sep 26, 2018 8:59 pm View latest post
No new posts GL profiles issues on Windows Riccardo Corsi General 11 Tue Sep 04, 2018 8:46 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP