OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Missing 'png' image reader


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [3rdparty]
View previous topic :: View next topic  
Author Message
sdef
Newbie


Joined: 25 Oct 2018
Posts: 4

PostPosted: Mon Nov 12, 2018 5:51 am    Post subject:
Missing 'png' image reader
Reply with quote

Hi,
I have built osg3.4.0 with eclipse oxygen and with dependencies
and it is successfully built. but png,btg files does not work and give Missing png plugin error?? pls help

OSG 3.4.0 failed to load png files.


Thank you!

Cheers,
Rajani
Back to top
View user's profile Send private message
kornerr
Appreciator


Joined: 01 Oct 2013
Posts: 300

PostPosted: Thu Nov 15, 2018 10:41 am    Post subject:
Missing 'png' image reader
Reply with quote

Hi.

Give us CMake configuration output, that would help.
On Wed, 14 Nov 2018 at 17:45, Rajani RV <> wrote:
Quote:

Hi,
I have built osg3.4.0 with eclipse oxygen and with dependencies
and it is successfully built. but png,btg files does not work and give Missing png plugin error?? pls help

OSG 3.4.0 failed to load png files.


Thank you!

Cheers,
Rajani

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=75186#75186








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Voerman, L.
Guest





PostPosted: Thu Nov 15, 2018 10:45 am    Post subject:
Missing 'png' image reader
Reply with quote

just guessing here... osgdb_png has a dependency on libpng - and libpng is not in your PATH or app dir (windows) or LD_LIBRARY_PATH (*nix)Laurens.


On Thu, Nov 15, 2018 at 11:41 AM michael kapelko < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:

Quote:
Hi.

Give us CMake configuration output, that would help.
On Wed, 14 Nov 2018 at 17:45, Rajani RV < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:

Hi,
I have built osg3.4.0 with eclipse oxygen and with dependencies
and it is successfully built. butĀ  png,btg filesĀ  does not work and give Missing png plugin error?? pls help

OSG 3.4.0 failed to load png files.


Thank you!

Cheers,
Rajani

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=75186#75186





_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------
Post generated by Mail2Forum
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General [3rdparty] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Write Image From texture Generated by... GarfieldPig General 1 Wed May 08, 2019 11:42 am View latest post
No new posts Missing features with GL Core profile Hugal31 General 1 Tue Apr 16, 2019 11:23 am View latest post
No new posts Image capture in memory icf80 General 12 Fri Apr 12, 2019 6:11 pm View latest post
No new posts Image::copySubImage freqfly General 0 Tue Dec 04, 2018 12:32 pm View latest post
No new posts TIFF plugin reader does not handle im... Eric Sokolowsky Submission 0 Sat Sep 29, 2018 2:30 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP