OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

hidden geometry in embedded osg


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Meldryt
User


Joined: 02 Mar 2016
Posts: 63

PostPosted: Thu Feb 21, 2019 7:17 am    Post subject:
hidden geometry in embedded osg
Reply with quote

edit: i changed my old question, because i have searched in the wrong direction.

I have an osg 3d scene running as standalone or embedded in an opengl plugin.
For the embedded version i use the GraphicsWindowEmbedded, but the rest of the osg code is the same.

The embedded version is running fine except of invisible geometry inside of my PagedLOD nodes, created with osgDB::ReaderWriter.

I tried playing around with different StateSet attributes.
Code:

geom->setRenderingHint(osg::StateSet::TRANSPARENT_BIN)

When i set these, i can see the geometry. When i turn my camera so that the geometry normal is parallel to my camera look direction it disappears. Shocked
Unfortunately i have no access to the main application and don't what is different compared to my standalone app
(f.e. applied opengl states, graphic context).

I have already tried push&pop opengl state in the draw loop of the plugin when i call viewer->frame(), but it didnt solve the problem.

What is the best way to track down the problem? Is there a helper function to print out all state flags for example?

_________________
OSG Version: 3.4.1
OS: OpenSuse Leap 42.1
Back to top
View user's profile Send private message
Meldryt
User


Joined: 02 Mar 2016
Posts: 63

PostPosted: Thu Feb 28, 2019 1:42 pm    Post subject:
Reply with quote

i fixed it by setting:
Code:
stateset->setRenderBinDetails(11,"RenderBin");

_________________
OSG Version: 3.4.1
OS: OpenSuse Leap 42.1
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Intersection with 2d plane embedded i... mean_taipan General 5 Tue May 21, 2019 12:18 am View latest post
No new posts Layered rendering with a geometry shader AnyOldName3 General 8 Tue May 14, 2019 11:25 pm View latest post
No new posts Retrieve the triangles indices array ... Paradox General 1 Mon May 13, 2019 11:16 am View latest post
No new posts show mouse cursor in embedded osg Meldryt General 1 Thu Feb 28, 2019 5:13 pm View latest post
No new posts osg::Drawable vs osg::Geometry NoeMurr General 2 Sun Oct 21, 2018 2:45 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP