OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Memory not being released, causing crash


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Juanelm
Newbie


Joined: 18 May 2013
Posts: 5

PostPosted: Thu May 16, 2019 10:15 pm    Post subject:
Memory not being released, causing crash
Reply with quote

Hi,

I have a problem where when I create a OSG scene, then delete it, apparently the memory is not being released. I say this because if I re-open the scene 3 times, the 3rd time the textures show partially black, and the 4th time I close and re-open the scene, the program crashes. It seems to me it's reaching a memory limit. If I use a scene with bigger textures, it crashes on the second re-open.

I'm deleting all children under the root group, setting the viewer scene data to null, and deleting everything before re-opening the scene. What could be going on?

Thank you!

Cheers,
Juan
Back to top
View user's profile Send private message
robertosfield
OSG Project Lead


Joined: 18 Mar 2009
Posts: 12342

PostPosted: Fri May 17, 2019 8:34 am    Post subject:
Memory not being released, causing crash
Reply with quote

Hi Juan,

There isn't any way we can know precisely what is wrong given the lack
of specifics. All we can do at this stage is ask questions about what
you are doing and make general questions.

For instance you saying you are deleting a scene and re-opening a
scene. What do you actually mean. In the OSG you don't explictly
delete objects, you should be using ref_ptr<> to manage all scene
graph objects. What do you mean specifically by "re-open", load it
from disk?

What type of viewer/windowing are you using?

What OSG version/platform are you using?

My recommendation at this point would be to create a small test
program that demonstrate the usage case you are using in a way that
minimal but sufficient enough to demonstrate the problem. Such as
small test program can also be shared with others in a way that allows
them to do a code review and spot problems, or run the program on
their own systems to see if it reveals what the issue might be.

Robert.




On Thu, 16 May 2019 at 23:22, Juan Cruz <> wrote:
Quote:

Hi,

I have a problem where when I create a OSG scene, then delete it, apparently the memory is not being released. I say this because if I re-open the scene 3 times, the 3rd time the textures show partially black, and the 4th time I close and re-open the scene, the program crashes. It seems to me it's reaching a memory limit.

I'm deleting all children under the root group, setting the viewer scene data to null, and deleting everything before re-opening the scene. What could be going on?

Thank you!

Cheers,
Juan

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=76114#76114








------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts OpenSceneGraph-3.6.4 released robertosfield General 1 Fri Jul 26, 2019 3:16 pm View latest post
No new posts Image capture in memory icf80 General 12 Fri Apr 12, 2019 6:11 pm View latest post
No new posts Rendering stats crash on FreeBSD with... Michael Danilov General 0 Sat Dec 22, 2018 2:15 am View latest post
No new posts osgText crash with multiple Viewers ravidavi General 3 Tue Dec 18, 2018 8:50 am View latest post
No new posts osgText 3.6.3 crash Trajce Nikolov NICK General 2 Wed Sep 12, 2018 12:25 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP