OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Need explanation about a strange behaviour with


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Robert Osfield
Guest





PostPosted: Thu Nov 06, 2008 9:26 am    Post subject:
Need explanation about a strange behaviour with
Reply with quote

Hi Sukender,

My guess is that the problem is not related to the bin management,
rather missing vertex colour or vertex normals on some of the
geometry. If it's not this then perhaps you have transparency issues.

Robert.

On Thu, Nov 6, 2008 at 12:34 AM, Sukender <> wrote:
Quote:
Hi,

I found a strange behavior, and I would like someone to explain, if possible.
In an ".osg" model (exported from Blender) the "rendering_hint OPAQUE_BIN" line in some StateSets causes my model to be lit in a funky way. It is sometimes correctly lit, sometimes not (looks like diffuse got away). In my app, I have:
- a pStateset->setRenderBinDetails(11,"RenderBin") used to render HUD components,
- and a pStateset->setRenderBinDetails(-1, "RenderBin") elsewhere for my sky sphere.

But if I change "OPAQUE_BIN" to "DEFAULT_BIN", then my model is correctly lit...
Can someone explains what happened?
Thanks.

Sincerely,

--
Sukender




------------------
Post generated by Mail2Forum
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Happy New Year to all OSG Users Chris Hanson General 0 Mon Jan 07, 2019 10:17 am View latest post
No new posts osg-users Digest, Vol 138, Issue 27 Zachary1234 General 0 Tue Jan 01, 2019 1:16 am View latest post
No new posts osg-users Digest, Vol 137, Issue 14 poweruserm@live.com.au General 0 Fri Nov 16, 2018 11:16 pm View latest post
No new posts General Users starting questions in O... A Z General 1 Mon Oct 15, 2018 3:59 am View latest post
No new posts osg-users Digest, Vol 136, Issue 8 jonasydy General 0 Wed Oct 10, 2018 12:40 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP