OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Trying to install osgPPU in winXP


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU]
View previous topic :: View next topic  
Author Message
argosen
Newbie


Joined: 15 Apr 2010
Posts: 6

PostPosted: Thu Apr 29, 2010 9:04 am    Post subject:
Trying to install osgPPU in winXP
Reply with quote

Hi,

I am trying to install the 0.4 version of osgPPU. [WinXP]
When I try to configure the code, cmake says:
Code:

CMake Error at CMakeLists.txt:244 (INCLUDE):
include could not find load file:

OsgPPUCPack

I have tryed to find that file manually, but it is not in the package.
Anyone know where could be the problem?

P.D.: I have not nVidia card, so I have not CUDA suport. It shouldn't be the problem, but who knows.

Thanks for your time!

Cheers,
Jon[/code]
Back to top
View user's profile Send private message Send e-mail
argosen
Newbie


Joined: 15 Apr 2010
Posts: 6

PostPosted: Thu Apr 29, 2010 9:49 am    Post subject:
Reply with quote

Hi,

OK, I dissabled BUILD_OSGPPU_PACKAGES checkbox, and now it generates the project.

I hope it could work like this.

Thank you!

Cheers,
Jon
Back to top
View user's profile Send private message Send e-mail
allensaucier
Appreciator


Joined: 10 Apr 2009
Posts: 126

PostPosted: Fri Apr 30, 2010 2:57 pm    Post subject:
Reply with quote

Hi argosen
I've gotten osgPPU 0.4 to work on windows like that. never had a prob w/ the CMakeLists.txt file, though.

I used CMake 2.6 for windows - with the GUI. I executed the CMake GUI, opened osgPPU_040 as my source directory, choose osgPPU_040/build as the build directory, cleared my cache - Under the File Menu I believe - and then clicked the configure button once.

CMake ran and showed me a lot of things in red. I checked off the box for installing the data so that the data files would be installed, eventually.

I then clicked configure again, the red went away and I clicked generate.

After that, I executed MSVS 2005/v8; opened the sln file found within the build directory what was allocated during configure/generate stage.

I then chose to build all from within the solutions manager. I, too, did not get cuda to build but everything else did.

I then chose to build the "install" probject, which actually installs osgPPU in your OpenSceneGraph directory if that is the way you set it up during the configure stage.

Hope this helps.

Cheers,
Allen
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts bug: Openscenegraph-3.4 branch instal... remoe General 1 Thu Sep 29, 2016 2:57 pm View latest post
No new posts Install msvc debug files along with t... Ralf Habacker Submission 2 Mon May 30, 2016 10:13 am View latest post
No new posts Contemporary multipass non-OsgPPU glo... Chris Hanson General 1 Mon Dec 14, 2015 8:47 pm View latest post
No new posts Install osgViewer/config headers scrawl Submission 1 Sat Nov 21, 2015 7:02 pm View latest post
No new posts install error : libEGL.so does not exist yoshiyuki yamamoto General 1 Fri Apr 24, 2015 9:04 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP