OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgPPU with osgART


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU]
View previous topic :: View next topic  
Author Message
norbykov
Newbie


Joined: 25 Jun 2010
Posts: 2

PostPosted: Fri Jun 25, 2010 8:32 pm    Post subject:
osgPPU with osgART
Reply with quote

Hi,

I'm trying to add some glow to a scene controlled by osgART, and I was wondering if someone could point me in the right direction. I used osg version 2.8.2, and osgPPU 0.4.2-rc1, and everything is fine except that I see my glowing scene on a black background instead of the web cam video. I tried every possible scene structure I could think of, but I either get a black screen, the original scene without glow and with the webcam feed, or the glowing scene with black background. I used part of the glow example code, and I am wondering if I'm missing some important part. I'm not sure what other info you need to be able to give me some hints, but I'm hoping someone came across something similar, and can help me figure this out.

My other question is, is there a change that osgPPU doesn't work well on ATI Radeon cards? I tried the basic glow example on my other PC (ATI Mobility Radeon HD5470, Windows 7 64Bit), and the screen turned yellow, with some artifacts all over, and I could barely make out the rotating scene under that yellow mess. I copied the data folder, and did everything I thought I needed to make it work. I do get a warning (detected OpenGL error after RenderBin::draw(,) Any hints on that? I appriciate all and any help. Smile


Thank you!

Cheers,
Norbert
Back to top
View user's profile Send private message
norbykov
Newbie


Joined: 25 Jun 2010
Posts: 2

PostPosted: Thu Jul 01, 2010 11:47 am    Post subject:
Reply with quote

Hi,

Well, I actually made it work, using additive blending. Smile

And I found out that the shaders from the osgPPU svn trunk work fine with ATI cards, so all is good Smile


Thank you for your time though!

Norbert
Back to top
View user's profile Send private message
a.terenzi
Appreciator


Joined: 03 Sep 2009
Posts: 226

PostPosted: Fri Jul 02, 2010 5:15 pm    Post subject:
osgPPU with osgART
Reply with quote

Hi Norbert,
could you post a working example (source code) showing how you integrated OsgART with osgPPU?

Thanks.
Alessandro

On Thu, Jul 1, 2010 at 1:47 PM, Norbert Kovacs < (
Only registered users can see emails on this board!
Get registred or enter the forums!
)> wrote:
Quote:
Hi,

Well, I actually made it work, using additive blending. Smile

And I found out that the shaders from the osgPPU svn trunk work fine with ATI cards, so all is good Smile


Thank you for your time though!

Norbert

------------------
Read this topic online here:

http://forum.openscenegraph.org/viewtopic.php?p=29591#29591






_______________________________________________
osg-users mailing list
(
Only registered users can see emails on this board!
Get registred or enter the forums!
)
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Contemporary multipass non-OsgPPU glo... Chris Hanson General 1 Mon Dec 14, 2015 8:47 pm View latest post
No new posts Osgart plugins skitl General [3rdparty] 0 Tue May 27, 2014 9:38 am View latest post
No new posts osgART android dnpro General [3rdparty] 0 Fri May 16, 2014 3:57 pm View latest post
No new posts 3ds max to osgArt export problem mossin General [3rdparty] 0 Thu Mar 06, 2014 8:40 am View latest post
No new posts 3ds max to osgArt export problem mossin General [3rdparty] 0 Sat Oct 26, 2013 4:08 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP