OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

VS 2010 and OSG v2.8.3?


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General
View previous topic :: View next topic  
Author Message
Paul Martz
Guest





PostPosted: Tue Jul 20, 2010 6:43 pm    Post subject:
VS 2010 and OSG v2.8.3?
Reply with quote

Hi all -- Has anyone successfully built OSG v2.8.3 with VS 2010? Back when we
did 2.8.3 release testing, I vaguely recall some people reporting (successful)
build results using VS 2010, but just wanted to make sure this actually works.

Thanks.
--
-Paul Martz Skew Matrix Software
http://www.skew-matrix.com/


------------------
Post generated by Mail2Forum
Back to top
dglenn (David Glenn)
Appreciator


Joined: 07 Jan 2009
Posts: 209
Location: Burbank, Calif. U.S.A.

PostPosted: Wed Jul 21, 2010 10:26 pm    Post subject:
Reply with quote

Greetings!

I would like to know too before I go out and buy VS 2010.
Well, I guess that I could go out and try it on the trial version. Right?

If it doen't, then I'm just use the VS 2008 that I have acess to.

D Glenn

_________________
David Glenn
---------------
D Glenn 3D Computer Graphics Entertainment.
www.dglenn.com
Back to top
View user's profile Send private message Visit poster's website
dzenanz (Dženan Zukić)
User


Joined: 02 Sep 2009
Posts: 61

PostPosted: Thu Jul 22, 2010 2:46 pm    Post subject:
Reply with quote

Hi,

I just compile-tested OSG 2.8.3 with VS2010, x64 target. It has build errors (full log attached).

Furthermore, I cannot switch to VS2010 because Qt doesn't support it at the moment.

Cheers,
Dženan
Back to top
View user's profile Send private message Send e-mail
Keith Parkins
Guest





PostPosted: Thu Jul 22, 2010 3:11 pm    Post subject:
VS 2010 and OSG v2.8.3?
Reply with quote

Quote:
From your log it looks like the only problem you are having, which I
encountered as well, is the new C++/stl problem. You need to add:

#include <iterator>

to the header file NodeCallBack. This should get rid of most of the
errors, but you may have to add the above include to other files as
well.

Say you build it again and get:

5>GraphicsContext.cpp(680): error C2039: 'back_inserter' : is not a
member of 'std'
5>GraphicsContext.cpp(680): error C3861: 'back_inserter': identifier not
found

Then add "#include <iterator>" to GraphicsContext.cpp.

Try just editing NodeCallBack's header because it needs to be there and I
think it catches most of the other undeclared back_inserter calls.

-K


On Thu, 22 Jul 2010, D??enan Zuki? wrote:

Quote:
Hi,

I just compile-tested OSG 2.8.3 with VS2010, x64 target. It has build errors (full log attached).

Furthermore, I cannot switch to VS2010 because Qt doesn't support it at the moment.

Cheers,
Dženan


Keith Parkins U of R Center for Visual Science


------------------
Post generated by Mail2Forum
Back to top
dzenanz (Dženan Zukić)
User


Joined: 02 Sep 2009
Posts: 61

PostPosted: Thu Jul 22, 2010 3:17 pm    Post subject:
Reply with quote

Hi,

Thanks for the tips, they may come in handy once Qt 4.7 is out and I start migrating to VS2010, and new version of OSG which includes those "includes" is not published.

Thank you!

Cheers,
Dženan
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts regard: &nbsp; how&nbsp; to&a... 韩志平 General 0 Mon Feb 13, 2017 6:57 am View latest post
No new posts how to load 3rdparty-x86-vs-2010.zip 韩志平 General 0 Mon Feb 13, 2017 5:52 am View latest post
No new posts build osg 3.5.4 plugin lua error, on ... namdt40 Plugins [osgPlugins] 4 Mon Aug 08, 2016 7:11 am View latest post
No new posts OSG Build with Visual Studio 2010 appollosputnik General 3 Mon May 06, 2013 1:30 pm View latest post
No new posts Windows: osgscribe.exe built in Visua... cbuchner1 General 1 Tue Mar 12, 2013 4:27 pm View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP